Error creating sys-usb

When installing Qubes I opted to use sys-net for both networking and usb. I now want to create a dedicated sys-usb but when I run sudo qubesctl state.sls qvm.sys-usb in dom0 I get an error. The sys-net state is entirely in red and says:

ID:            sys-net-usb
Function:      qvm.prefs
Name:          sys-net
Result:        False
Comment: The following requisites were not found:
                                                        sls: qvm.sys-net

At the end of the output I get

Summary for local
Succeeded: 3
Failed:          1
Total states run:        4
Total run time: 496.791 ms
DOM0 configuration failed, not continuing

The states that succeeded are hide-usb-from-dom0-uefi, qubes-input-proxy and sys-usb-input proxy

I’ve tried running the command with sys-net shut down but I get the same result.

Thank you for any help.

EDIT: Qubes is installed on a laptop. Both keyboard and trackpad work with sys-net disabled so there is no risk of locking myself out. My goal here is to create a sys-usb VM and pass through my mouse to dom0 while continuing to use my build in keyboard for now. I also want to improve my security by shielding sys-net from all plugged in USB devices.

I also chose the option to use sys-net also as sys-usb while fresh installing 4.1 and then failed to to create a separate sys-usb. You can fix it like this:

In dom0

$ sudo qubesctl top.enabled pillar=True

You will see sys-net-as-usbvm listed there.

Then I had to clean the “leftovers” of the failed command to create sys-usb:

$ sudo qubesctl state.highstate

And finally to get rid of sys-net-usb:

$ sudo qubesctl top.disable qvm.sys-net-as-usbvm pillar=True

Runnning sudo qubesctl state.sls qvm.sys-usb now worked as expected.

Thanks to marmarek for his comment in bug #6754.


Which one is more secure :

  • sys-usb
  • sys-net as sys-usb

Or check all of them !!