Editing guid.conf, permission denied

Greetings Qubes community. I just finished installing Qubes on my laptop yesterday. It’s running ever so smoothly and I’m very excited about the whole experience. :smiley:

So I noticed that when I install a new VM that I can’t run it full screen/maximized. Googled it. Found out that’s done on purpose as a security measure. However if you still want to run VM’s full screen or maximized, you can do so by editing the guid.conf file in /etc/qubes/. But Qubes isn’t allowing me to edit the file. Most likely this has to do with root access. Qubes recommends not creating a root account though. So I didn’t. Didn’t think I would need it anyway. :laughing:

Is there another way to edit this file currently? Or do I have to reinstall and create the root account to do it?

Thank you.


I hope I posted in the right place. :crossed_fingers:

Hi @Virtuel,
without editing guid.conf, you can manually switch a window to fullscreen with the Alt-F11 shortcut, see the last section of full-screen-mode:

Note: Regardless of the settings above, you can always put a window into fullscreen mode in Xfce4 using the trusted window manager by right-clicking on a window’s title bar and selecting “Fullscreen” or pressing alt + f11 .

Note: if you want to edit guid.conf, use sudo (sudo vim /etc/qubes/guid.conf).

^ this. Also, on a typical system it would ask you for the “root” password when writing sudo. But qubes doesn’t need this.

For anybody else seeing this thread, the following points to the documentation about the guid.conf.

Hi @ludovic @deeplow,

Thank you for the response. I don’t remember how, but I somehow got it in my head that Vi was not installed. Wich is why I thought I could not open the file without root. I was using the cat command, hehe. :yum:

I had not gone online yet so I had no way of downloading packages either. Sorry for my mistake and I appreciate the help. :+1:

Onto the next problem. :laughing:

1 Like


1 Like