Edge scroll in Toughbook CF-31 is driving me nuts please help

Please does anyone know how to disable edge scrolling for the following device in libinput, bear in mind xinput isn’t available in Qubes dom0. So I’ve been trying to figure out how to do it with the libinput config files to no avail, I couldn’t find a match for edge scrolling.

Also I’d like to possibly increase the sensitivity/accuracy of the touchpad (it’s a cf-31 toughbook non-capacitive touchpad)

Device: ImPS/2 Generic Wheel Mouse
Kernel: /dev/input/event4
Group: 6
Seat: seat0, default
Capabilities: pointer
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: disabled
Nat.scrolling: disabled
Middle emulation: disabled
Calibration: n/a
Scroll methods: button
Click methods: none
Disable-w-typing: n/a
Disable-w-trackpointing: n/a
Accel profiles: flat *adaptive
Rotation: n/a


I can suggest to first figure out whatever this is a Qubes OS issue or general Linux (or Fedora specifically since dom0 is based on Fedora 37 for Qubes OS 4.2) issue.
Try to boot from Fedora Live USB image and check whatever you can disable edge scroll there or not.