Easiest way to setup i2pd

So I just installed qubes a few days(rather new to linux in general) ago and so far I’ve managed to get my sys-vpn and regular i2p working relatively easily. I’m stuck on i2pd however.

I followed the install instructions found here:
Installing - i2pd documentation

I made a debian-11 based template and ran the following:
sudo apt-get update
sudo apt-get install i2pd

However once it finished I have no way of running any commands related to it. I tried all the commands listed here:

Nothing seems to work however. What mistake am I making? Is there anyone that knows what I’m doing wrong?

When I install in a fedora-37 template and type i2pd in the terminal it will start and give me an error that the web console couldn’t start as well as a bunch of other things.

I also tried to followed a guide (can only link twice per post) to make sys-i2pd with a qt gui.

But when I got i2pd-qt running i2pd woulndn’t work in the browser(I setup and port 4444) and it said it couldn’t find tunnels.conf.

Anyone that can point me in the right direction?

EDIT: Ok got it to run in the debian-11 template by building from source. I keep getting the following errors:
20:59:47@104/critical - Daemon: Failed to start Webconsole: bind: Address already in use
20:59:47@104/warn - Addressbook: Can’t open /home/user/.i2pd/addressbook/addresses.csv
20:59:47@104/error - Addressbook: Resetting eTags
20:59:47@104/critical - Clients: Exception in HTTP Proxy: bind: Address already in use
20:59:47@104/critical - Clients: Exception in SOCKS Proxy: bind: Address already in use
20:59:47@104/warn - Clients: Can’t read /home/user/.i2pd/tunnels.conf: /home/user/.i2pd/tunnels.conf: cannot open file
20:59:47@104/critical - Clients: Exception in SAM bridge: bind: Address already in use

Any idea how to fix this?

Cayce has made a very nice salt package to easily setup i2p on Qubes OS: https://codeberg.org/cayce/sys-i2pd

Unfortunately, some forum Mods have been getting in trouble with her and she has been banned or left the forum.

Anyways, you can try contacting her on Codeberg.

Here, the thread I found.

Debian 11 has old and incompatible version i2pd. Use the i2pd from debian 12 templates. It works on there.

See Qball answer. That version can slice through sys-whonix. You can add i2psnark+. Use i2p forums for details. http://333.i2p or http://retrobbs.i2p and you’ll get more answers (maybe even a template… don’t hold your breath).

Tried the debian-12 template and I could get the console up by going to and it shows:

Uptime: 4 minutes, 56 seconds
Network status: OK
Tunnel creation success rate: 47%
Received: 761.99 KiB (1.51 KiB/s)
Sent: 790.05 KiB (2.38 KiB/s)
Transit: 0.00 KiB (0.00 KiB/s)
Data path: /var/lib/i2pd
Hidden content. Press on text to see.
Routers: 227 Floodfills: 177 LeaseSets: 0
Client Tunnels: 41 Transit Tunnels: 0

However I cannot browse the internet with my browser configured to and no .i2p websites will load. I tried letting this run for several hours.

Ok I think I figured it out. If and only if I use the I2P in private browsing extension AND configure the browser for and I have to make sure I put http:// before the i2p address, then it works. If anyone knows how to get it going without the extension it would be much appreciated. Thanks for the help.

Check out these two videos: