Dual-boot installation: Qubes. Kali 2023

Hi there,

Some months ago I installed Qubes (uname -r reads: 6.1.43-1.qubes.fc37.x86_64) in my notebook using less than a half of the 480GB SSD, I left the rest unpartitioned. Now I installed Kali 2023 in the same disk (no money here to buy another one). I know it is not ideal, that there are security risks, but for the time being this is for testing and learning. (I don’t want to install it inside a qube for now as Qubes is already not very fast on this old PC). While doing the Kali installation I choosed guided partitioning and I did not take notes! (big error). After rebooting grub loads as usual with the Qubes options and then Qubes loads normally. So I searched the forums and I followed some guidelines but I am probably doing something wrong. I modified /etc/grub.d/40_custom in Qubes dom0 adding this:

menuentry "Other Linux" {
set root=(hd0,1)
chainloader +1

and executed

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

after rebooting I received this error:

error: disk 'hd0,6' not found.

, so I pressed e at the grub menu and changed it to hd0,2 then I pressed F10, as it said

Booting a command list    error: invalid signature

I changed to 3, 4, 5, 6, 7, 8 but nothing worked,

To make things worst I tried this 2 methods in order to show you the very long output of fdisk -l but nothing worked: How to copy from dom0 | Qubes OS

Did you try to copy from dom0 clipboard to global clipboard using the Qubes Clipboard widget?
When you press on “Copy dom0 clipboard” do you see the notification that clipboard content was fetched from dom0 and its size?
Does global clipboard work for copying the clipboard between other qubes?

I am using nano, I’ve followed instructions found on the web to select the text and then I tried alt+6 and then I clicked on “copy dom0 clipboard” but no notification showed up and no text is pasted. After that I tried selecting the text and pressing ctrl+k with the same results. I haven’t tried copying the clipboard betweeb other qubes but if that can help I can try. Is it any other text editor available at dom0? I read that many people find it problematic copying text to the clipboard in nano.

I’ve tried vim and I have the same results. Copying using the edit copy at the terminal windows works but it is not the best because it can copy only what I see on the screen at any given time, so for long texts it means a lot of copy paste. To top it up internet is so slow and with many websites not loading most of the times.

Use Ctrl+Insert to copy selected text from any terminal or you can also use Ctrl+Shift+C to copy from dom0 terminal. You can also right-click with mouse to copy.

You can print the whole file in the terminal using cat or parts of it using tail and head.
You can also copy the file from dom0 to some qube and use any text editor that you like there.

1 Like

running at dom0:

qvm-copy-to-vm default-dvm fdisk.txt
stat fdisk.txt
sh: line 1: zenity: command not found

sudo qubes-dom0-update zenity
Using sys-firewall as UpdateVM to download updates for Dom0; this may take some time...
Unable to detect release version (use '--releasever' to specify release version)
Fedora 38 - x86_64          0.0 B/s | 0 B  03:33
Errors during downloading metadata for repository 'fedora':
   - Curl error (7): Couldn't connect to server for https://mirrors.fedoraproject.org/metalink?repo=fedora-37&arch=x86_64 [Failed to connect to mirrors.fedoraproject.org port 443 after 18607 ms : Couldn't connect to server]

I also tried using my phone as access point and I have the same results. Both internet connections work fine at other devices with Xubuntu & Android.

I managed to copy and paste all the contents of a txt file at dom0 into another file in default-dvm but I am having difficulties to copy that file to a usb stick so I can put it in another pc in order to send it to pastebin

I’m not sure why or where zenity is required.
What command did you run to see this error?

sh: line 1: zenity: command not found

The command I issued is the one you can see in my post:

That’s strange, I don’t have zenity installed in dom0 and it works for me on Qubes OS 4.2.

But I think I have Qubes 4.1, not 4.2 (as uname -r reads: 6.1.43-1.qubes.fc37.x86_64). I can’t update as the internet is so so slow. Any help please to solve it so I can apply the pending updates? Thanks

fc37 means you have Qubes OS 4.2.
Is it a clean install or did you upgrade from Qubes OS 4.1?

I am not sure, is it any way to know all the upgrades applied until now? Do you think you can help me troubleshooting the very slow internet? thanks

I don’t know of a way to check it.

What’s your network configuration?
Are you connected to internet using WiFI?
Are you using VPN/Tor?
If you boot from another OS (e.g. from some Linux Live USB) on the same PC where you have Qubes OS then will network work properly there?

How can I check that?




You can try to use kernel-latest for your sys-net (or whatever qube that has your PCI wireless controller attached), maybe it’s a problem with your wireless controller driver.
The kernel-latest package for dom0 kernel (not sure if needed), and kernel-latest-qubes-vm to install kernel-latest for your qubes.

I have a problem with the DNS as it can’t resolve the URLs, but maybe there is something else as using the destination IP address (instead of the URL) did not solve it. The wifi adapter I am using is located inside the notebook but I also tried a wifi adapter (with a different chipset) connected to a USB port and until now I continue having the same problems. Any commands I can use to diagnose it?

Do you have internet working but it’s very slow or internet is not working at all?
Try to ping some addresses in sys-net terminal:

ping quad9.com

Before seeing your message I connected another USB wifi adapter (Ralink RT2870/RT3070) and now it works at a reasonable speed so I applied the updates. The adapter that comes with the computer is a Broadcom BCM4313.
Answering your question: It was working very slow and then it wasn’t working.
After this updates and reboot I tried again with the Broadcom adapter but I don’t see ant improvement, the zenity error remained so I installed it in dom0 and now the qvm-copy-to-vm works!.
Going back to my original post: Here I pasted the contents of the fdisk -l at dom0 as I think it may help to solve my problem with the Kali installation:

What do you have in /boot/efi/EFI directory?

sudo ls /boot/efi/EFI /boot/efi/EFI/*