Drive not detected in BIOS after installation

I’m having issues installing Qubes onto my Forced-EFI (AMD 5800H, 3060) Laptop.
Dell apparently no longer ships laptops with Legacy support.

I managed to get Qubes (3.2.1; 4.0.4 is having issues loading a .c32 file) to install through Virtualbox via a sudo’ed VMDK link to the rawdisk (my 1TB 980); but now that I (confirmed) install, the drive doesn’t show up as a bootable drive in EFI when I try to map the .EFI file, nor in boot options as a bootable option. I’ve booted back into Mint and verified that everything was setup correctly. Drive is encrypted, password is correct, and the bootable partition’s on there. Model’s a G15 5515 Ryzen Edition. I know, new hardware, just doesn’t seem right.

Any ideas?

Have you looked through this?

1 Like

For Dell BIOS to recognise it you must use the UEFI installer. You can hack it to install in legacy, but afterwards the BIOS refuse to recognise the drive.

Also, Dell BIOS typically requires modifications to the ISO files, see the link above.

The main issue I’m having with that is that the Dell model I have doesn’t permit legacy booting. I’m trying to find a way to modify it to be UEFI only. I’ve ran through the NVIDIA troubleshooting document as well.
I’ll give this a shot and let you know here in the near future.


Do you happen to have a link to the UEFI installer? The one I have (4.0.4) has the screen go black shortly after receiving a wall of text even though I’ve ran through all of the NVIDIA troubleshooting.

You need to edit the ISO file, as per the instructions in the link, see:

Installation freezes before displaying installer


Change xen configuration directly in an iso image

I’ll give it a shot here in a moment, restoring the disk image as we speak.

Thanks for the assist. I’ll let you know what I find.

So, after a lot of back and forth. The closest that I get is that xen.cfg is blank, but I still can’t make the drive come up as a detectable boot option even after editing it to fit the kernel version and making an EFI entry. The BIOS still sees the drive itself, just not that it’s a bootable option.

I’m so confused. Ran through the last part of the guide to try and get the thing to work; no luck.

Did you try doing the “Boot device not recognized after installing” section of that as well? I have needed that many times.