Dracut timeout possibly caused by udev failure?


Sorry if my grammar is unclear. English isn’t my first language.

I’ve been experiencing the dracut timeout error and some sort of hardware failure in the screen that comes before the plymouth installer in the past few days. I know the former had been covered many times on this forum and the Installation Troubleshooting guide, but my problem seems to be a little different. I’ve tried 4 different USB flash drives (both 2.0 and 3.1) and 4 different flashing programs (balenaEtcher, dd, Rufus in dd mode, and GNOME Disks), and yet I always get the exact same message.

I noticed that something that was different with my error messages was a udev failure. Apparently, the error (here’s a reddit post with the exact error message) said that it tried to initialize some sort of hardware device for 3 minutes and eventually just gave up, which is strange to me because my specs (listed at the bottom of this post) are nearly identical to the recommended ones listed here. I did some research on reddit and some other forums and found out that it might have had to do with my NVMe SSD, which is also odd because Qubes recommends those.

These raise three questions for me:

1) Am I interpreting these error messages wrong, and if so, what do they mean?
2) What does this problem indicate?
3) How can I fix this, if I can?

Unfortunately, I can’t fetch error logs from the dracut emergency shell because my USB peripherals are disabled in the terminal and I don’t know any other means of accessing them.


PC specs:
AMD Ryzen 3 3100 @3.6GHz
16GB DDR4 RAM @3.2GHz
Samsung 980 250GB
AMD Radeon RX 580

Try to switch storage mode from RAID to AHCI in BIOS or disable Intel Volume Management Device (VMD) (or something similar for AMD?) in BIOS.


Turns out I had NVMe RAID mode disabled and SATA Mode toggled to AHCI on my manufacturer (ASUS)'s UEFI by default. As for an Intel VMD equivalent, I think there isn’t one…?

AMD has not described any features of their Zen architecture that sound particularly similar to Intel’s VMD or the NVMe remapping feature of Intel’s consumer platform chipsets, so it’s not clear what hardware features (if any) are helping to enable their NVMe RAID implementation.

  • anandtech

Thanks for trying to help

Maybe you have this issue:

1 Like


Thanks. I’ll look into this tomorrow and get back to you if anything happens.

Disabling SMT worked. Unfortunately, I was planning to use that feature for some heavy HVMs, though. I’m going to make a new thread asking for Qubes-friendly substitutes to that, unless there’s already a thread covering that which I wasn’t able to find. Sorry if this is a little too much for this thread.

Thank you

You can add x2apic_phys=true to Xen options in your grub instead of disabling SMT.

1 Like