Don't boot with replaced motherboard

I changed my motherboard to a new the same model.
And my Qubes OS don’t boot now with message:

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key_

My Qubes OS disk partitions are accesable with Qubes USB.
I already changed the boot options from “Legacy Only” to “UEFI”, this didn’t work to boot my Qubes OS.

How-to save current Qubes OS installation without reinstall the OS?

You probably need add EFI entry manualy. Lost EFI entry in boot menu after removing and re-connecting drive - #11 by 51lieal

1 Like

Great. Thank you!
I just started my Qubes OS.

This helped me:
efibootmgr -v -c -u -L "Qubes OS" -l /EFI/qubes/grubx64.efi -d /dev/nvme0n1p1 -p 1