Dom0 will not update to completion

When I receive update available notifications for dom0 in the tray and accept the update process, dom0 updating never runs to completion. I have tried updating dom0 with and without other vm updates, when they are also available. If I eventually try to cancel the update(s), I get a cancelling updates message, but cancellation does not happen. At present I have a (Dom0)Qubes OS Update window on screen with dom0 showing and an in progress blue bar and the message Interrupting the update… The only way I can get out of the loop seems to be to completely shut down the computer and then reboot.
In Qubes Global Config - Updates, my Dom0 update proxy is sys-whonix, with Enable stable updates only and Check for and notify me about dom0 updates both checked in the boxes.

1 Like

Tor is working very slowly recently, seems like it’s under a DDoS:
Clearnet link:
Is there currently a major DDOS affecting the network's availability? - Support - Tor Project Forum

You can check what’s going on with the dom0 updates by running this command in dom0 instead of using Qubes Update tool:

sudo qubes-dom0-update
1 Like

Thanks apparatus! I have your method running presently and it has completed 30% in 11 minutes. Looks promising and I’ll leave it running. I didn’t know about the Tor situation. cheers

1 Like

A note about using qubes-dom0-update instead of Qubes Update tool or salt command:

1 Like