Dom0 update issue?

dom0 seems to be having an update issue. I daily get a notice via the Qubes update program symbol in the task bar that dom0 has an update available. I run it and it shows “updating dom0”. When it is done it is showing the green checkmark as completed. But when I open details of the update it is showing local : ----------. It has been doing this for a couple weeks. I just wanted to ask it this is normal behavoir? I would think that it should only show an update is available when there is an update available. Not doing a daily update when nothing seems to be changing.

I’ve never had your particular issue but in my experience problems with the updater can 99% of the time be solved by running the command line updater, which in the case of dom0 is qubes-dom0-update

Same here and I think it’s normal behaviour, whenever no packages were updated but some other stuff in dom0

I’ve bad luck with the updater… I start an update and it just hangs with no visible activity. I observed the same response with Fedora, Dom0 and whonix. doing command line updates worked fine, but if I recall reading that using the updater tool supposedly provides additional security, so I’m not sure what I’m losing.

That’s briefly mentioned here and covered in more detail in this pull request. (Keep in mind that the latter hasn’t been approved or published, so it’s more like my personal, unofficial understanding of the situation.)

It has also been discussed pretty extensively in threads on this forum, which you can find by searching.

Try clearing the cache using the qubes-dom0-update utility and then run it again to update it. In the pop-up (sys-firewall?) Window you may see what exactly is trying to update, and then the dom0 output from that update transaction. If the update still fails you should see a clue as to why it failed there.

Managed to setup this cacher vm from unmans ‘task manager gui’ and after it works fine a few weeks I nowadays getting errors in most of the updates (pic attached).
cacher’s netVM is sys-whonix (followed by sys-firewall and then sys-net)
updateVM is sys-whonix for all updates…

error is always …[attached]

What is that error message

Most probably you have to be patient a bit and then to try again. You still have it?

I have issues with dom0 update through Qubes Update right now.
It hanged on me for 5 hours now. I pressed cancel, but it says that it will wait for current qube to finish updating. Just great. Very helpful. :person_facepalming:

This is my problem with this new update mechanism and with graphical update utilities in general - the lack of feedback. How am I supposed to know what it’s doing in the background?
Does it not have a basic timeout or what? Basic things. B-a-s-i-c. :angry:

How can I manually abort this process without running into problems with my installation?

Yes, did that too - always the same…
Regardless if cacher is attached to sys-firewall or to sys-whonix. Same error/result

Always those “failed o fetch” messages, as if it don’t have a connection.

Hi, I’m getting the same issues, which seem to have started after an in-place system update from qubes 4.0 to 4.1. Every other day or so, I get the update notification icon on the menu bar telling me there are updates available for dom0. However, after going through the update process for dom0, the result is “local : ----------”, with no packages updated as far as I can see.

In the last couple of weeks, since I started noticing the problem, I have also had one genuine dom0 update, where I got the notification, went through the update process for dom0, and got a standard output telling me a couple of packages had been successfully updated.

Running qubes-dom0-update from the terminal and clearing cache have made no difference so far.

1 Like

This is the result when there are no updates available.
You could confirm this by running sudo qubes-dom0-update.

It sounds as if you are seeing a spurious notification: I dont see this
on a clean 4.1 install.

I started with clean install of early 4.1 beta, and updating since then to 4.1.1 today, and I’m seeing this once in a while…

I am getting occasional real updates in dom0 also. So I am assuming that this is normal behavior for dom0 update now.

I am also assuming that one of my previous update started this behavoir. I do not see any real harm with it doing it. Just seem like a waste of CPU time.

Thanks for everyone replyl. I am closing this post if possible for me to do now.

Hidden Templates

Did you realize that you can also download and install the kali linux via the command line?

Use this:

sudo qvm-template install kali

I wouldn’t do that.
The template is built on bullseye, not bookworm, and will need full
dist-upgrade, with variable results.

I never presume to speak for the Qubes team. When I comment in the Forum or in the mailing lists I speak for myself.