Dom0 not getting updates via gui updater


I usually update my system with the gear icon in the top right, as recommended in the docs. I realized my dom0 hasn’t updated in quite awhile (a few months) so i ran sudo qubes-dom0-update and got like 27 updates and 2 new packages.

Why is my system not updating dom0 through the gui updater? Is this a problem and how do I fix it?


What is your “dom0 update qube”?

It is sys-firewall. Also in global settings I have check for dom0 updates checked.

My configuration is mostly default 4.1



Read the Qubes update page for instructions on how to update in order to avoid this issue: How to update | Qubes OS

1 Like

I’ve read that doc before and it said not to use qubes-dom0-update and to use the gui instead. That must have changed.

Thanks for the heads up.

That’s right; it’s a temporal solution before the bug is fixed.

There is a lot of misunderstanding about #6585 (see this thread). It seems unlikely that it alone would be the cause of your problem unless, for example, your ethernet cable has been unplugged for the past couple of months. You probably would’ve noticed that in other ways!

Since the qubesctl commands are just the command-line equivalents of the graphical Qubes Update Tool, if the former worked for you, then that doesn’t really explain why the latter seemingly didn’t. In this case, it would be useful to know what happened (i.e., the actual output) when you tried running various update commands in a terminal.

There was an issue about checking dom0 updates availability: No dom0 update notification · Issue #7437 · QubesOS/qubes-issues · GitHub
It is fixed now, but dom0 update needs to be forced (either by calling qubes-dom0-update manually or by selecting “Enable updates for qubes without known available updates” and then selecting “dom0”).

1 Like