Dom0 exhibits unsolicited persistence between boots

Is this a bug I should report or have I just broken my install?

Dom0 appears to retain some state memory after shutting down, even when battery is removed and power button pressed a few times to exhaust all power and to clear ram.

The first iteration was two unsolicited instances of the qube manager window appearing together on every boot.

The first instance has cleared after a few days of unrelated system testing, and was immediately replaced with a new and equally unsolicited startup window, this time Dom0 terminal. This was after a use of Dom0 terminal followed by a shutdown.

I’ve not actually been entering any commands in Dom0 beyond lsblk and have barely changed the system from stock: one template clone with some snapd.

How could this be happening? Is it a broken install? A qubes feature? Does the fact that i’ve been removing batteries and hard-drive (in that order) for testing and formatting for reinstall possibly suggest i’ve damaged the SSD or forced it to write some parts of itself twice? Even if that’s an explanation, I have not made a startup rule on either machine, so how has the system reached this output?

In will be interested to see if you get some replies here. I posted about a persistent dom0 terminal that boots up every time I start qubes. Like you, it started appearing for no reason and persists to this day. Unlike you I never used the dom0 terminal for anything so I have no idea why it happened.

One suggestion was to delete ‘~/.config/xfce4’ which I never did. I have just let it go and close it every time I boot up.

I have no such issues. Some logs might help, or what you are already suggested.

This is an XFCE thing.

  1. Open the XFCE Settings App and choose “Session and Startup”
  2. Under “General” make sure “Automatically save session on logout” is unchecked
  3. Under “Saved Sessions” push the “Clear saved sessions” button
  4. Shutdown and reboot your computer. You should no longer see what you have reported.
3 Likes

Thanks Sven I’ve been wondering about this but hadn’t really researched it yet.

-Kenny

I’ve been trying to do as Sven suggests above, but I can’t find this path. I’ve done a few things via “system tools”>“xfce terminal setting”, and “system tools” > “settings editor” but I don’t see anything about “session and startup” or “saved settings”. I also experience the OP’s problem so would like to fix it.

The closest thing I see is in “settings editor” where there is “xfce session” with “save on exit”, which is checked, but no “saved sessions”

Am I looking in the right places?

I don’t think it can be more intuitive: “System Tools → Session and Startup”

And if you don’t have that entry in Q-menu, then you probably have bigger issues than this.

Anyway, you can start it from terminal

$ xfce4-session-settings

Oooppss…

I was blinded by looking for “xfce” first and going in that way. My early morning rising had a temporary effect on my ability to see the obvious. Thanks so much as this fixed this irritating problem.

Interestingly, I posted this some issue some time back and had fixes suggested (that I quote above) that I didn’t pursue, thankfully. This was a much more intuitively sensible solution that worked. Thanks again.