Dom0 Error

Error: Failed to download metadata for repo ‘qubes-dom0-cached’: Cannot download repomd.xml: All mirrors were tried

1 Like

Without any context, there’s nothing we can do to help. Could you please shed more light on this situation?

the command was run in dom0 as:

sudo rpm -i 3isec-qubes-task-manager-0.1-1.x86_64.rpm

Are you absolutely sure you don’t have any ongoing/cancelled dnf transaction?

I’m asking since this command should have nothing to do with plain rpm.

This tutorial documents what I’m trying to achieve:

And are you sure that running rpm -i causes this message to appear?
I cannot see any rpm -i invocation in the tutorial.

1 Like

sorry you are right; it’s:

sudo dnf install ./3isec-qubes-task-manager-0.1-1.x86_64.rpm

Wait! I thought that this error actually prevents you from installing the package.
This is not what happens in my case. It still gives me this error, but it prompts me for installation:

[user@dom0 ~]$ sudo dnf install ./3isec-qubes-task-manager-0.1-1.x86_64.rpm 
Qubes OS Repository for Dom0                    0.0  B/s |   0  B     00:00    
Errors during downloading metadata for repository 'qubes-dom0-cached':
  - Curl error (37): Couldn't read a file:// file for file:///var/lib/qubes/updates/repodata/repomd.xml [Couldn't open file /var/lib/qubes/updates/repodata/repomd.xml]
Error: Failed to download metadata for repo 'qubes-dom0-cached': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
Ignoring repositories: qubes-dom0-cached
Dependencies resolved.
 Package                       Arch        Version      Repository         Size
 3isec-qubes-task-manager      x86_64      0.1-1        @commandline       20 k

Transaction Summary
Install  1 Package

Total size: 20 k
Installed size: 52 k
Is this ok [y/N]: 

So if you happen to have the same case, can you just answer ‘y’ to the Is this ok question?

I don’t get the “Ignoring repositories: qubes-dom0-cached” option for some reason

You should be able to specify disablerepo=*