Does Qubes OS even still functional and maintained?


Last time I tried Qubes OS was probably 3-4 years if i’m not wrong.

I lately tried installing it to make some videos on how to use and configure it and what the hell is happening ? feels like nothing is working ?

I can’t update the Template VM’s, sys-net not working, no internet connection and consuming x5 since the last time I used it.

I’m I the problem here or just Qubes OS stoped being maintained ?

Thank you in advance.

Still maintained with a recent 4.2 release, and these basics should all be working from a fresh install at least. Any more detail on your setup?


Installed it on Bare-Metal 1 To, AMD Ryzen 7 7800x3d; 32G Ram

And yeah it was a fresh install that’s why I don’t really understand why is that happening…

1 Like

sys-net not working is where I’d start looking. Is the qube completely failing to start, or is it a problem with network manager?

Yes, sys-net stopped working ( even starting ) because the update of the TemplateVM failed for no reason…

There might be a salt option for reinstalling the templateVM from local data, but I’d suggest just backing up and then re-doing the install for simplicity.

Not great that this broke your setup. If it recurs, hopefully someone can help diagnose here.

ah fuck it, I re installed it and first thing can’t start personal qube… I’m out of this

Edit : Well, I fixed it 5sec before never touching Qubes OS againt for my whole life…

1 Like

Sorry to hear you’re having so many problems, @Sofiane. I’m not sure why this is happening in your case. FWIW, many other people (including me) are able to use Qubes without such problems, so it’s definitely possible. My only guess is that your hardware isn’t fully compatible with Qubes. Given your bad experience, I wonder if it would be better for the Qubes installer to just refuse to proceed if certain compatibility checks don’t pass rather than allowing the user to have a broken experience. :slightly_frowning_face:

Have you gotten some libxenlight error in the post-reboot setup while it was setting up networking? That sounds like the same error i got when i used the latest installer.

ngl I’ve been in that place a few times and I’m still here. Was it a fix worth sharing?