DisposableVM is persistent

Hi there,
I recently upgraded my default templates to Fedora 33. I followed these instructions to create a disposable VM template from Fedora 33:

The template shows up in the Qubes menu, as “Disposable”. But when I launch it, instead of creating a “DispXXX” instance, it launches as “fedora-33-dvm” and remains persistent: if I open a web page, close the VM, then re-open it, Firefox offers to restore the session.

How can I make the DisposableVM nonpersistent?

Thank you!

This is stange. By default it should open the a [dispXXXX] qube based on the DisposableVM Template, when you open it via the Qubes menu.

Although I was unable to reproduce it, I get the idea that that it could be related to missing the following step from the instructions you mentioned.

@StonecipherB Can double-check that you did that?

Thank you! I had run the command during the install, but it seemed not to have worked - I ran it again and now the machines are truly disposable rather than persistent. Thank you so much.

1 Like