Disposable VM inconsistent visibility in AppMenu

Continuing the discussion from Possible glitch in KDE menuing (and other menus too) for Qubes disposable templates:

I could use some thoughts or maybe some guidance on if this is a bug. Using @unman’s recommendation to use True instead of 1 solved the issue. However, I only needed to do this for one of the two new disposable VM templates. I am using the stock XFCE desktop environment, not KDE.

In creating two Fedora 38 disposable templates, I encountered inconsistent results Same commands, different templates, different outcomes.

I was following the guidance from creating a new disposable template. So, after creating the two Qubes template VMs, I ran the suggested three commands for the disposable template VMs:

[user@dom0 ~]$ qvm-create --template <TEMPLATE> --label red <DISPOSABLE_TEMPLATE>
[user@dom0 ~]$ qvm-prefs <DISPOSABLE_TEMPLATE> template_for_dispvms True
[user@dom0 ~]$ qvm-features <DISPOSABLE_TEMPLATE> appmenus-dispvm 1

Qubes Template → Disposable Template Name → outcome following the above were the following:

  1. fedora-38fedora-38-dvm → success, everything appeared as expected
  2. f-38-customf-38-custom-dvm → partial, no AppMenu entry but it is listed as an option for “disposable template” in the Qubes Global Settings GUI.

Switching to use True resolved the AppMenu issue for f-38-custom-dvm.

qvm-features <DISPOSABLE_TEMPLATE> appmenus-dispvm True

Differences between the two:

  1. fedora-38-dvm is based on a fresh install of fedora-38 from the Qubes repo.
  2. f-38-custom-dvm is based on an in-place upgraded Fedora 36 template, which has additional software installed, and correctly showed in the AppMenu.