Disp-mgmt-dvm requires what package?

First of all, very excited for the new forum. It was much needed.

Onto my problem, what package do I need for my disp-mgmt-dvm to successfully Qubes Update? I am using a minimal template for everything.

Is it possible that you’re encountering the problem described in this announcement?

I changed the template to fedora-32-minimal now, but I just get this error message:

Error on updating anbox: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=anbox', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 1 anbox: ERROR (exception list index out of range)

It sounds like anbox means you might be trying to emulate Android? That’s not currently supported, but perhaps this might shed some light:

That’s the name of my Anbox VM. The error is from the Qubes Updater. All other VM’s also give that same error message I posted.

Anbox works fine for me currently.

So the error message must mean I am missing some package. If I change the template to, say fedora-30 or debian-10 it works because they include many packages.
I will have a look at the docs and install packages related to minimal template customisation when i get the time.

Shifting to minimal templates is really long process in current scenerio, as Qubes doesn’t provide any minimal template at installation. And even if it provided, creating sys-net based on it will need package download. And it is also not useful to include networking packages to minimal templates by default. BTW I am using minimal ones for everything except default-mgmt-dvm. There is no documentation for needed packages for it.So you should better install At least one full template until this documentation issue resolves.

@9009: I can’t speak to Fedora, but I have created debian-mgmt by cloning debian-10-minimal and adding

  • qubes-core-agent-passwordless-root
  • xfce4-terminal (not necessary, but I prefer it when terminal is needed)
  • qubes-mgmt-salt-vm-connector

default-mgmt-dvm now uses debian-mgmt as its Template.

1 Like

I am using a debian-minimal based default-mgmt-dvm. Important AFAIK is
that you have installed the salt stack related stuff
(qubes-mgmt-salt-vm-connector).

/Sven


public key: https://www.svensemmler.org/0x8F541FB6.asc
fingerprint: D7CA F2DB 658D 89BC 08D6 A7AA DA6E 167B 8F54 1FB6

1 Like

Can confirm that qubes-mgmt-salt-vm-connector is the only needed package for a fresh debian-10-minimal template to be used as a mgmt-dvm.

1 Like

Are you guys sure as when I tried to test it today, I needed both qubes-mgmt-salt-vm-connector and qubes-core-agent-passwordless-root. When I wasn’t having passwordless root, It didn’t worked for me. I tested it on fedora-32-minimal.

1 Like

Yes, passwordless-root is also required, i think.

1 Like