Disabling sys-gui-gpu from commandline?

Once sys-gui-gpu has been installed and the GPU assigned to it, if the machine spontaneously reboots while starting qubes (presumably sys-gui-gpu itself), do we have a boot flag to disable it ?

More generally, I could not locate in the official doc a list of qubes-specific boot parameters.

See here: Autostart troubleshooting | Qubes OS

Thanks, that does the trick.

In case there would be no boot param to help here, I’was trying to get access to the dom0 filesystem though various boot media, but I was rather puzzled how bad luck I had:

  • debian 11 netinst in rescue mode accepted the luks password, and listed me all LV’s to choose a rootfs from… except that in /dev/mapper/ I can only see the swap partition,
  • the latest Qubes 4.1 signed alpha (20210409) in rescue mode tells me `you don’t have any Linux partitions"

… while booting the on-disk 4.1 managed to find the partitions all by itself.

It may be interesting to note several things:

  • even when no GPU gets assigned to sys-gui-gpu, qubes has to be started with skip_autostart, now that I have qubes-input-proxy-sender installed: as soon as this domain starts, the PS/2 keyboard and touchpad are not sending events to dom0 any more, and the Qubes display appears frozen to the user. Short pressing the power button to bring the logout dialog causes sys-gui-gpu to stop, which unlocks the system
  • sys-gui-gpu is autostarted, even though the “start automatically on boot” checkbox is not checked, and default_guivm is still dom0. What is it using to get started ? That seems to imply we have to qvm-remove until we manage to get it working, can’t we keep it installed and inactive between two attempts ?