Disable Secure Boot on Qube

Hello people. After a few weeks, I was finally able to passthrough my GPU to my standalone Windows VM. Everthing seams to be working fine, but when I try to install the Nvidia drivers with GeForce Experience, it takes about 7 minutes and show an error message:

This Nvidia driver is not compatible with this version of Windows

After consulting some Nvidia guides, updating Windows, and asking Gemini, it replied me with:

If your Windows VM is configured with Secure Boot enabled (common in some Qubes setups), you might need to disable it temporarily for the Nvidia driver installation to proceed. Refer to the Qubes documentation on Secure Boot for specific instructions [invalid URL removed]. Remember to re-enable Secure Boot after successful driver installation for security reasons.

I’ve been searching all over Qubes forum and website, and didn’t find a thing about secure boot on a qube.

Pre-passthrough observations:

To be able to attach my GPU devices on the Windows qube, I’ve forced dom0 to use Intel Integrated Graphics by creating a /etc/X11/xorg.conf.d/20-intel.conf configuration file:

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "BusID" "PCI:MY:INTELGPU.BUSID

Section "Screen"
  Identifier  "Default Screen"
  Monitor     "eDP-1"
  Device      "Intel Graphics"

similarly to this guide, to make the Nvidia card available to the qube.

After that, I’ve followed this other guide to identify GPU IOMMU group, and add them on Qube’s qube devices tab configuration.

A PCI bridge was indicated as part of the same IOMMU group as the Nvidia GPU, but since it gave the error Non-endpoint pci devices cannot be assigned to guests , I didn’t attach it to the qube.


Anyways, my two main questions are:
1. How can disable and enable secure boot on a qube?
2. Is there an equivalent to lspci on Windows so I can be sure the GPU can be seen by the VM in the first place?


1 Like

That’s some AI nonsense.
There is no Secure Boot in qubes:
enable Linux kernel gpg verification in grub and/or enable EFI Secure Boot for Qubes / Xen guests · Issue #5241 · QubesOS/qubes-issues · GitHub

You mean lspci? You should be able to see the GPU in Device Manager. If there is no driver for it there should still be Unknown device there and you can check its PID:VID to see if it’s your GPU or not.

Thank you. I did open Device Manager with and without the GPU attached, in both cases there is an unknown PCI device.

However, with the GPU attached there are two new devices displayed there:
A Microsoft Basic Display Adapter with an error message:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31
The driver trying to start is not the same as the driver for the POSTed display adapter.

(The POST thing reinforced me to think it was something about secure boot or some boot related thing)

And an High Definition Audio Device, that seams to be working without problems.

The unknown PCI device has an error message:

The drivers for this device are not installed. (Code 28)
There are no compatible drivers for this device.
To find a driver for this device, click Update Driver.

(When I clicked it, Windows could not find drivers for the device.)

Again, I’m not sure if this unknown PCI is actually my Nvidia GPU, since it is displayed with or without the Nvidia card attached to the qube. I’m thinking to give more attention to the Microsoft Basic Display Adapter and the High Definition Audio Device .

Again, tks for helping.

Get the device VID:PID in device properties and search for it to see what device is it:

1 Like

Thanks! According to Device Hunt, my nonfunctional display adapter is in fact my Nvidia GPU. And the unknown PCI device is a Xen Platform Device. Do you think it’s malfunctioning has something to do with me not being able to install the Nvidia drivers?

At this point I’m not sure if it’s a Qubes related question or a Windows/Nvidia one, or both. I’m out of ideas.

If your issue is not being able to install NVIDIA drivers because of this error:

This Nvidia driver is not compatible with this version of Windows

Then the error message is clear that you’re trying to install driver on unsupported Windows version. E.g. you’ve downloaded NVIDIA driver installer for Windows 10 but trying to install it on Windows 7.

It is not that simple. Many people got this error message even downloading the right drivers (besides, I’m using GeForce Experience). Anyways, I think it should be better to close this topic and, if it’s an actual Qubes related problem, open another question about it.