Disable NVMe RAID on AMD x399

I was having a lot of trouble trying to install Qubes in UEFI without CSM.

I was able to install without CSM enabled, but unable to actually boot the OS after installing.

The HCL shows a few people installing on x399, but said they needed legacy (CSM) enabled.

The problem turned out to be that I had (by default?) NVMe RAID mode enabled in the BIOS, simply disabling this allowed everything to work flawlessly.

Posting this here to hopefully save sombody else the hours (days) I spent troubleshooting in rescue mode messing around with xen configs.

1 Like

A bit more background:

Obviously I was trying to install to an NVMe drive. I also dont dont actually know why I cared (or should care) about using UEFI without CSM

I followed all the UEFI troubleshooting in the Official Qubes documentation

I followed all the guidance in Fom’s giant list of Qubes OS workarounds

I tried creating the installation media on different USB sticks, using different settings, using different software, I tried buying a new and extremely overpriced USB 2 stick (seriously why do these things cost so much more than USB 3 sticks…) following all the above steps each time.

Yes, the definition of insanity is trying the same thing over and over again expecting different results. Yes, I might be little bit insane.

It wasn’t until I was finally successful installing on a SATA drive without CSM that I got a bit suspicous. I noticed I could boot when I installed to a SATA drive in AHCI mode instead of AMD-RAID mode.

Buried deep without the settings of my x399 mobo i found that NVMe was in RAID mode.

Disabled NVMe RAID and installed perfectly without following any of the aforementioned troubleshooting steps.

Now I haven’t actually tried to fix any of the power saving settings like suspend/hibernate, so I can’t attest to those working on x399, although that might have more with using nvidia GPUs

Now its time to figure out PCI Passthrough for nvidia