Disable NVMe RAID on AMD x399

I was having a lot of trouble trying to install Qubes in UEFI without CSM.

I was able to install without CSM enabled, but unable to actually boot the OS after installing.

The HCL shows a few people installing on x399, but said they needed legacy (CSM) enabled.

The problem turned out to be that I had (by default?) NVMe RAID mode enabled in the BIOS, simply disabling this allowed everything to work flawlessly.

Posting this here to hopefully save sombody else the hours (days) I spent troubleshooting in rescue mode messing around with xen configs.

1 Like

A bit more background:

Obviously I was trying to install to an NVMe drive. I also dont dont actually know why I cared (or should care) about using UEFI without CSM

I followed all the UEFI troubleshooting in the Official Qubes documentation

I followed all the guidance in Fom’s giant list of Qubes OS workarounds

I tried creating the installation media on different USB sticks, using different settings, using different software, I tried buying a new and extremely overpriced USB 2 stick (seriously why do these things cost so much more than USB 3 sticks…) following all the above steps each time.

Yes, the definition of insanity is trying the same thing over and over again expecting different results. Yes, I might be little bit insane.

It wasn’t until I was finally successful installing on a SATA drive without CSM that I got a bit suspicous. I noticed I could boot when I installed to a SATA drive in AHCI mode instead of AMD-RAID mode.

Buried deep without the settings of my x399 mobo i found that NVMe was in RAID mode.

Disabled NVMe RAID and installed perfectly without following any of the aforementioned troubleshooting steps.

Now I haven’t actually tried to fix any of the power saving settings like suspend/hibernate, so I can’t attest to those working on x399, although that might have more with using nvidia GPUs

Now its time to figure out PCI Passthrough for nvidia

1 Like

Did you install on the nvme with RAID on then switched to AHCI after completing the install and booting?

Or did you install and boot with AHCI enabled?

I am having the same issues, can install, but cannot boot, doesn’t recognize nvme during boot. this is with AHCI enabled. I install LinuxMint onto the exact same machine with same BIOS settings, and it installs and boots with no issues.

Both from bootable USB drives.


Small note, nVME and AHCI are interface specifications. nVME was created specifically as an improvement over AHCI. In general you cannot switch between the two, a device will either support one of the other. If you’re using an m.2 connector, the drive could either be AHCI/SATA or nVME.

Qubes would install in RAID mode, it but it would not boot in UEFI (it would boot in CSM mode)

Qubes install works with RAID disabled, and boots with UEFI.

If you install in RAID mode, you cannot disable it without needing reformat the drive and reinstall.

I also HIGHLY recommend that you always avoid the RAID settings in your motherboard. It will cause compatibility issues, and will cause significant issues recovering your data if your motherboard fails. having an epic RAID 60 will be worthless if your motherboard dies.

There’s no benefit to being in RAID mode. Even if you could get it to work, unless you have multiple drivers it will only hurt performance by adding extra overhead. Same deal goes with SATA drives in RAID mode.

A hardware RAID controller (usually a PCIe card) will offer better performance. Otherwise, if you need RAID features, you’re better off using Stripped or Mirrored LVM volumes for better flexibility and compatibility.

tl;dr just disable whatever fancy “RAID” modes are available and reinstall, and never enable those settings ever again.

Thank you for the great explanation on this one.

Definitely clarifies what My BIOS selections are.

It is on an M2 SSD that I am trying.

Will setup my settings better now that I understand thank you again.

You will need to check specifically what interface your SSD uses. Manufacturers have been deliberately misleading consumers by confusing “m.2” with nVME.

They have been taking advantage of this confusion to sell overpriced SATA drives in the m.2 form factor, offering very little benefit over tradational SATA SSDs