Disable internet

Hi guys.

When I choose net qube “none” for a qube I still can apt update with the update proxy qubes uses, how can I disable Internet connection for a qube (appvm in my case) completely?

If you choose “none” as netVM, the qube will not have the Internet. Updates in Qubes are performed via a proxy:

AppVMs are not “updated” but Templates are. AppVMs get their root filesystems (and installed software) from their Templates:

See also:

1 Like

I did understand that but I also want to disable the proxy for updates in my “none” network vms, if that is somehow possible

You can create a separate template and switch off updates in its preferences. All AppVMs based on it will not be updated.

1 Like

I dont know if Im dumb, but I dont find the option to disable Internet/switch off updates for the template

It is different with different distros, so it would be helpful to tell which particular template you are trying to swith the updates off for.

Also, this helped me a lot in my digital life.


Are you sure that you are trying with AppVM an not TemplateVM ? There are no policy that an AppVM could do apt update or updating vm.

Yes Im sure its a APP vm, it has no Internet when curl smth or using the browser but when I use apt update in console it starts downloading.

Debian 11 qubes 4.1 @enmus

can you try shutdown the vm, make sure that netvm is set to none, then try to run apt update again.

If your ``debian-11 template based AppVm is set with NetVM to none, then you shiould get something like this on trying sudo apt update

Err:1 Index of /r4.1/vm/ bullseye InRelease
Temporary failure resolving ‘deb.qubes-os.org

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
All packages are up to date.
W: Failed to fetch https://deb.debian.org/debian/dists/bullseye/InRelease Temporary failure resolving ‘deb.debian.org

W: Failed to fetch https://updates.signal.org/desktop/apt/dists/xenial/InRelease Temporary failure resolving ‘updates.signal.org
W: Some index files failed to download. They have been ignored, or old ones used instead.

But, if it’s the output is something like this

sudo apt update

16 packages can be upgraded. Run ‘apt list --upgradable’ to see them.

Then I suspect that it is a template you are talking about.
If you still claim it is AppVm, please describe how you created it, with commands, etc… Or try to create new one based on debian-11 template, switch the net to none, and try again

Sorry, @51liea, I didn’t see your post.

Netvm is set to none, I restarted all qubes now, still apt update connects.

I created a new one still I get an output like this

sudo apt update

16 packages can be upgraded. Run ‘apt list --upgradable’ to see them.

Networking is set to none sys-net is also set to none.
I really dont know why that happens

Please describe how you created new app qube, step by step. Are you sure you didn’t clone the template actually?

It “works” now after restarting my laptop, but still when I try to apt-get install it shows me new packages to update and finds also the app I mention after apt-get install, where does the vm get the information from without internet?
But after clicking “yes” it shows me failed to fetch.

Also it would be good to know where I can disable updates for template vms

Especially read @adw 's post there