Disable gui on boot

How is it possible to disable the gui on boot?

On my first boot of QubesOS there was the systemd verbose output visible and no gui. How can I configure it back?

you can press anykey (i usually press F1) to get verbose output.

Can this also be changed permanently without having to press a key?

1 Like

in dom0, edit /etc/default/grub then remove rhgb and quiet (if you want to see boot messages) from kernel option, rhgb is stand for redhat graphical boot.

after that update your grub config.

That was my first thought too, but where is grub?

oh then just remove those option in /boot/efi/EFI/qubes/xen.cfg I assume you use r4.0 legacy ?

1 Like

sudo nano /etc/default/grub
sudo grub2-mkconfig -o /boot/grub2/grub.cfg
or /boot/efi/EFI/qubes/xen.cfg ?

1 Like

Thank you, it worked! :grinning:

1 Like