Disable automatic updates for Arch linux templates

I want to disable the automatic updates for the arch linux template and manage the updates by myself.
Currently the update-manager always shows needed updates for the template.
This might be related to the rolling release in Arch linux.

I followed the instructions from Disable Qube updates for a specific qube - #6 by cpp977 and selected qubes-update-check in the list and disabled the entry for my arch linux template. But I still get always the notification that the template needs to be updated.

Is there anything else I can do?

Thanks for help!

Any hint for how to achieve this?

The below command removes the current notification icon from the VM where you execute it :
/usr/lib/qubes/qrexec-client-vm dom0 qubes.NotifyUpdates /bin/sh -c 'echo 0'
The same command with echo 1, add the current notification icon.

If you really disabled the update detection, the notification icon will not come back, else it will.

To go deeper, read and understand the systemd units:

  • qubes-update-check.timer
  • qubes-update-check.service

and associated shell scripts.

1 Like