Detailed help qubes backup on Verbatim USB hard drive

I have read the Qubes Documents “How to backup Qubes” and “how to use a USB device” several times and followed the advice as best I can. I can’t get the backup drive connected. Backup Qubes in the Qubes Tools menu. I choose not to backup untrusted or debian-11-dvm because they are empty. I connect the Verbatim disk in Qubes Devices to sys-firewall and use that as the target qube. In the … tab, I get a listing of the Verbatim volumes and Other Locations. I can’t find the directory I created on the Verbatim drive.

If you do not connect your USB drive to any AppVM, you should be able to see it in sys-usb and browse its filesystem with, e.g., Nautilus. Does it work?

If yes, try connecting it to some AppVM using Devices widget and its files/folders should be available in that AppVM like above. Does it work?

By the way, I wouldn’t use sys-firewall qube for that. It has its own important task and you don’t want to compromise it. I would create a special qube for that, or use a disposable one.

I can open sys-usb and open File Manager and choose the partition on the USB hard drive formatted as vfat which has 1 folder titled backup. If I open debian-11-dvm and attach the USB hard drive to it, I can see the backup folder in the partition. However when I run Backup Qubes and set the target qube to either sys-usb or debian11-dvm with backup directory /backup, it fails. I figured out that I had to enter the path identified by the …, /media/user/XXXX-YYYY/backup. That seems to be working. Is this correct?

1 Like

It worked up to 64% when it failed with message "file too large 32768+0 records in and out, 4.3 GB, 4.0 GiB copied. Do I fix this in the debian-11-dvm AppVM? All this could be documented and save us time.

From the name, this qube looks like a disposable VM template and not a disposable VM. The latter should have names like DispXXXX. The former is used to create new disposable VM; if it’s compromised, all dispVMs will be compromized too.

This looks like a problem with the filesystem on your USB hard disk. Is it FAT32? See this: Backing Up Hangs at 4GB (USB Stick)

I created a vm called verbatim-qube with net qube of sys-usb. I attached the verbatim USB hard drive to it with command “qvm-usb attach verbatim-qube sys-usb:2-1” I then opened Qubes Backup and selected verbatim-qube as target and entered the directory as /media/user/XXXXXX/backup where i got the XXXXX from the directory icon … Then I chose Next and Next again to start the Backup. The backup seems stuck on 7%. the verbatim USB drive is formated as ext4 with a backup folder. I have looked at the verbatim-qube.log but don’t see any problems. Any suggestions?

It look like this at least to me

1 Like

I still need help in setting up a Qubes backup with Verbatim USB hard drive formatted as ext4 with user as owner and group and one /backup folder. I am using Qubes 4.1.0 and fedora 34 as default templates.
I can connect the Verbatim drive to work qube and view the folder in /media/user/XXXXXXXXXXXX/backup. When I run Backup Qubes and specify the target qube as work and the directory as noted above, the backup fails. I need suggestions

Stupid question, but maybe your USB drive has damaged sectors?
Are there any error messages within your backup mount qube?
Has this worked for you on 4.0 with the exact same hardware/software configuration?

Dumb answer. the USB drive works to backup other linux computers. there are no other error messages.
Not everyone on this forum has used Qubes since 2012. I just started with 4.1.0


Could you confirm, that the mentioned problem is not identical to yours?

Especially relevant ist the fs on your qubes system or a RAID setup for it.

I am running Qubes 4.1.0 on a Thinkpad T480 with 32 GB memory and a
256 GB M2 SSD. NO RAID. All VM’s are based on Fedora 34, linux kernel

And your filesystem for / is ext4? If not this might be your problem.

Other than that this sounds fine.

You could try to run qvm-backup --verbose as the CLI might give you more verbosity.

Maybe this is a problem with a specific qube, so trying to backup them individually might help finding the broken one.

If no logs in dom0 nor the backup mount-point-qube give any errors… Then i would consider a reinstall and test again.

the backup file system is ext4. I have the standard default qubes. Tried the CLI qvm-backup --verbose backup_location work. The backup disk was attached to the work qube It stopped at 17.89% with message [MainProcess selector_events.init:59] asynchio: Using sector: EpollSelector. It only tried to backup the work qube.

Solved. I created an AppVM qube verbatim with net qube of sys-usb. I attached the Verbatim backup drive to the verbatim qube. I started Backup Qubes with a target qube of verbatim and a directory of /run/media/user/XXXXXXXXXXXXXX/backup. Backup ran until it reached 100% and the directory of verbatim showed a file qubes-backup-2022-05-04T13556 using 4.6GB space.

This shouldn’t be necessary as you don’t need networking, and since sys-usb doesn’t have a netvm attached you won’t get an internet connection anyway.

1 Like

I am totally lost here.

For the sake of me (and hopefully other user too) what is the difference between “failure” and “solution”? Probably I’m misreading something.

1 Like

I think the differences are using “/run/media/user…/backup” in the backup location and attaching the verbatim hard drive to the verbatim cube with sys-usb:sda1 attached to sys-usb. I have verbatim and sys-usb qubes running via Qubes Manager. I tried it again and it still works.

Oh, now I see. Thanks. So from the beginning you actually didn’t choose external disk properly as a backup location?