Backing Up Hangs at 4GB (USB Stick)


This is probably a trivial fix, but I am rather vexed by it.

I’ve written a little bash script which rsyncs my files to a remote sever and also to a cloud storage service. This handles my day to day backups.

However, I want to take a snapshot of the device every month or so, as I’ve a few AppVMs which I’ve tweaked and I don’t want to have to go back and figure out what I did. I also want to be spin up a new instance of my current set up incase my current laptop dies.

I’ve tried using the BackUp Qubes. I have just under 40 gigs worth of ‘Qubes’.

The process I’ve tried is as follows:

-Increase Private Storage for the Disposable Fedora template to 70 gigs
-Plug in a 64gb USB to the device and attach this to the disposable fedora template
-Run the backup of all qubes bar the Disposable Feodora template, pointing to the USB device.
-This runs fine, until we hit about 4gbs then it hangs. When I cancel I get a ‘file to large’ error. This has happened about 4 times.

Do I need to increase private storage somewhere else? Is there something I’ve missed?

Check the filesystem in the USB stick. It’s likely FAT32

The solution is to format your USB stick with some other filesystem ext4, for example (linux only). You can use a software like Gnome Disks to do it. Or simply from the file manager hit “format” on the USB stick (keeping in mind it will erase everything on it in the process).

1 Like

Wonderful - thank you.

I will do that, yes the disk is Fat32.

I will also, having read some of the other threads on this, test the backup!

1 Like

Just to confirm, this worked. Backup is now where it should be. So thanks again @deeplow

Oddly, reformatting the USB stick to ext4 was less trivial than expected.
I tried the format option in Fedora (Files → Format) but that didn’t do / open anything.
I tried the Properties → Open in Disks → Format, but that seemed to reformat the drive as something other than ext4.

In the end I ran mkfs.ext4 in a Debian template (may have been an option in Fedora, but I don’t use it outside of qubes so am more comfortable in Debian CLI). This worked.

I then had to CHMOD 777 the stick when it was mounted in Fedora as I was getting a no permission error. Is that normal?

Glad it worked well for you :slight_smile:

Unfortunately sometimes that happens. Is it possible you attached just one partition instead of the whole device? On the little Qubes-devices widget there are devices that show on top and ones that show on the bottom. Choosing the ones on the bottom is likely what you wanted.

Related reading: