Dell XPS 17 9720 Qubes 4.1 install

Dear community,
I’m trying to install Qubes 4.1.1 on my new Dell XPS 17 9720.
Whatever I do I always get the following error message:
Not asking for VNC because we don’t have a network” / “X startup failed, aborting installation”.
I’ve just found in HCL that this model was successfully installed by @Aaron_Brown.

Please help me to troubleshoot the graphics issues.

Thanks,
Arkadi

Hi there,
welcome!

Did You tried this: Installation troubleshooting | Qubes OS
?

Would You like to share with us what’s happened during troubleshooting?
Thanks a lot,
cheers,
M.

1 Like

Hi,

Thank you for the prompt response.
I’m a new in Qubes and I guess I was not too accurate in reproducing the troubleshooting sequence.
That what I did:

  1. I checked my BIOS. It doesn’t support a legacy mode. Boot Mode: UEFI only
  2. I disabled a secured boot in BIOS
  3. While installation from the Qubes USB I entered GRUB, moved the selection to the first choice, and then pressed the E key.
    The following text appeared:
    multiboot2 /images/pxeboot/xen.qz console=none
    module2 /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=QUBES-R4-1-1-X86-64 plymouth.ignore-serial-consoles quiet
    module2 /images/pxeboot/initrd.img
  4. I added at the end the following line:
    noexitboot=1 modprobe.blacklist=nouveau rd.driver.blacklist=nouveau
    (I also tried nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off)
  5. Then and I pressed F10

After a while I’ve got the error message:
“Not asking for VNC because we don’t have a network
X startup failed, aborting installation
The installation cannot continue and the system will be rebooted
…… “

My configuration:
Dell XPS 17 9720
CPU i9-12900HK
Graphics Intel Iris Xe + GeForce RTX 3060
Display 3840x2400 touch
BIOS 1.12.0
Memory 32GB

Thanks

Just to rule this out, what exactly do you mean with “at the end”?

You should put those parameters at the end of the kernel line, not at the end of the file:

Locate the three kernel= lines. Press the left/right arrow keys to position the cursor at the end of the lines, after rhgb quiet

Just for information, the complete troubleshooting for your laptop is here: [qubes-users] HCL - XPS 17 9720

And nvidia troubleshooting: Contents/nvidia-troubleshooting.md at master · Qubes-Community/Contents · GitHub

When I press “E” I don’t see any kernel= line.
Only the following 3 lines:
multiboot2 /images/pxeboot/xen.qz console=none
module2 /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=QUBES-R4-1-1-X86-64 plymouth.ignore-serial-consoles quiet
module2 /images/pxeboot/initrd.img

So I add the recommended text at the end.
I guess I do something wrong…

Please advise
Thank you

If you add the parameters in a new line, by themselves, they likely won’t have the effect you desire. Try adding them ad the end of line 2 (so it should look like this):

multiboot2 /images/pxeboot/xen.qz console=none
module2 /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=QUBES-R4-1-1-X86-64 plymouth.ignore-serial-consoles quiet nouveau.modeset=0 rd.driver.blacklist=nouveau video=vesa:off
module2 /images/pxeboot/initrd.img

If this doesn’t work, try the other options mentioned in the troubleshooting. At least now you know where to add them.

Alternatively you could try adding only nomodeset right after quiet.

This really helped and allowed me to move on to the graphical part of the installation.
I am so grateful to you!
During installation, I had to overcome the difficulty of reading microscopic letters on the screen (4K). Difficulties were also associated with terribly slow response times to any movement and mouse click, as well as screen refresh.
Eventually the installation finished with a single error message that occurred during Initial Setup:

[‘systemctl’, ‘start’, ‘qubes-vm@sys-usb.service’] failed:
stout: “”
stderr: “Job for qubes-vm@sys-usb.service failed because the control process exited with error code.”

Despite this error, the system boots and mostly functions.
The problem of small letters was solved by changing DPI.
However, the graphics problem has remained.
The link you sent me says that integrated graphics (i915) problems exist in kernel versions prior to 5.18. I found that I had kernel 5.15 installed and tried to upgrade it. It turned out that this is impossible because there is no network. The driver for my Intel® Killer™ Wi-Fi 6 1675 is not installed.

Could you please suggest a solution?

Thank you in advance

No problem. Please mark my suggestion as answer by clicking the button, so others can benefit from it aswell.

Run the following in dom0 as root:

I’m guessing your sys-net template is debian?

Could you please explane how to run as root?

Check this out: sudo - How do I run a command as the system administrator (root) - Unix & Linux Stack Exchange

Personally, I’d run sudo -i, execute my commands, then exit to return as user

After running the cat command and rebooting, the system starts to boot and already on the initial screens, a significant acceleration of graphics is noticeable. But after entering the password for the drive, I get the following screen:

and then nothing happens.

Before the disk password request, press the Esc key, you will switch from Plymouth graphic interface to text interface. On password request, enter the password.
In text mode, you will see the OS logs, and maybe you will get more information.

When I’m in text mode how can I get logs?

During the system startup in text mode, a hang occurs at the stage:
“Starting Light Display Manager
Starting Hold until boot process finishes up…”

See attached

Oh I see! Have you tried the guide here: https://www.qubes-os.org/doc/installation-troubleshooting/#not-asking-for-vnc-because-we-dont-have-a-network–x-startup-failed-aborting-installation–pane-is-dead-error-during-installation

Hi, did you manage to get this fully working, I.E. sound, mic, usb and graphics?

I am in need of a new computer and am planning on making the 9720 my next Qubes machine

Many thanks in advance