Dell XPS 15 9500


I must use 4.1 testing or it will not allow for an installation screen.

Like the Dell XPS 13 thread, suspend doesn’t work. It will blank your screen but after an hour later the laptop was still warm to the touch. To boot back up I had to hold down power button with no indication that it turned off (waiting 10 seconds) then it turned back on just fine. My commentary on this is that if I’m using qubes and encrypting my harddrive, perhaps shutting down each time isn’t the worst alternative.

Otherwise, works well.

Also, I’ve pasted the yml report below because I don’t have attachment privileges on the forums yet. I can edit and upload once these are granted.


Title: Qubes-HCL-Dell_Inc_-XPS_15_9500-20211114-221704.yml

brand: |
  Dell Inc.
model: |
  XPS 15 9500
bios: |
cpu: |
  Intel(R) Core(TM) i5-10300H CPU @ 2.50GHz
cpu-short: |
chipset: |
  Intel Corporation 10th Gen Core Processor Host Bridge/DRAM Registers [8086:9b64] (rev 02)
chipset-short: |
gpu: |
  Intel Corporation CometLake-H GT2 [UHD Graphics] [8086:9bc4] (rev 05) (prog-if 00 [VGA controller])
gpu-short: |
network: |
  Intel Corporation Comet Lake PCH CNVi WiFi
memory: |
scsi: |

usb: |

- works:
  qubes: |
  xen: |
  kernel: |
  remark: |
  credit: |
  link: |


Hey sorry, should’ve added this to the XPS post. I think I figured it out in a Github thread, but forgot to add it to my post here. Turning off hyperthreading in bios will fix the suspend issue!

The computer still has trouble shutting down sometimes though, you might need to hold down the power button there (ideally after Qubes has finished shutting down as far as it is capable).

Edit: hyper, not multithreading

1 Like

Forgive my ignorance here, but wouldn’t multithreading hurt the ability to virtualize?

Might have noticed this on power up today. After the regular power off from the menu, Qubes might have booted without me ever pressing the power off button. Will investigate further on my end.

Sorry, mistyped. I meant Hyperthreading, not multithreading. For context:

Safe use of Hyperthreading when Xen stable includes new sched-gran parameter · Issue #5547 · QubesOS/qubes-issues · GitHub

Hyperthreading (should) be disabled in Qubes (for security reasons), even if enabled in BIOS. For some reason though, disabling it in BIOS fixes the Suspend issue.

Thank you @YxU3BZB for your HCL report, which is now online.

I must use 4.1 testing or it will not allow for an installation screen.

Not entirely sure what you mean by that. The CI build? Did you try RC2?

1 Like

I used the download link with the section heading Qubes release 4.1.0-rc2. It has a text under it that mentions it is a testing release. This is why I called it 4.1 testing.

4.0.4 would not work at all for me; the installation screen would not ever come up when I tried booting from the usb that was flashed. I confirmed the usb worked by booting on another computer. When I read that the 4.1.0-rc2 worked for another dell user with the same graphics card, I tried that and it worked just fine.

1 Like

if you want to give it another shot on 4.04 stable version try this:

1.) Burn iso to the usb flash drive
2.) mount sda2(Boot Partition) i’m considering sda is your usb disk here.
3.) In [global] section choose: default=qubes
4.) Then add to the end of the kernel parameters under the [qubes] section: nouveau.modeset=0

This should fix it.

Make sure you have uefi enabled and secure boot off!