Dell XPS 15 7590 GUI problem's

Hi All, I need help I have been dealing with this issue for a week, it is so odd. I have a Dell XPS 15 7590 with a coffelake-h gt2 UHD graphics card but it also has an Nvidia card as well. But it is turned off.

The issue I am having is when I login Into my system from the light dm screen, everything is so small like unbearable I almost can’t read it, once I log in the same, small in dom0 and small in all the vms, also really weird behaviour from the cursor it shrinks when it’s on dom0 and grows when in vm?

I cant adjust the size, it doesn’t let me. I have tried changing the kernel parameters, playing with the dpi settings, went through so many of the forums to find similar problem and did find some but I haven’t been able to solve it.

I’m updated to the latest unstable kernel 6.1.1.-5
And Xen version 4.14.5.

Would anyone be able to help me get it all to normal size, or lead me to some documents to help me do it, it would be very much appreciated.

The screen is a 4k and touch screen .

The only solution that worked weirdly was I followed this
How to install software in dom0 | Qubes OS

These are the changes i made and it worked.
sudo nano /etc/default/grub
[update the following two lines, add if needed]
[save and exit nano]
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Now once I try and do it again it doesn’t work.
This solution fixed all the issues, cursor gui size text etc.

I never looked into this so I can’t give you a solution at the moment, but for the time being you could choose a lower resolution from the display settings, like 1920x1080.

Which solution are you referring to? Changing default kernel in dom0?
If so, when you’re booting you should be able to select the kernel when you’re in the grub menu. Then you can test the various options and note which one works best. Once you have that information, we can make the change permanent.

Hi thanks for your reply, I was referring to this solution, but it didn’t hyperlink the exact section


sudo nano /etc/default/grub
[update the following two lines, add if needed]
[save and exit nano]
sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Once I made this change, after I rebooted and logged in everything was fine. Then I rebooted again and it was back to everything being small…

Reboot and when you reach grub press E, then check if those options are present. If they’re not, manually add them, then press CTRL + X to boot and verify if that session seems ok.

This way we’ll know for sure if those parameters solve your issue.

Okay I will try that now, where exactly do i put in those parameters?

Open a terminal in dom0 and run:

grep GRUB_CMDLINE_LINUX /etc/default/grub

You will see some parameters that will also be in grub. Place the options you found in the previous solution after the last parameter you see here (but in grub).

I ran the command in dom0 and it returned nothing, ill just go to the grub menu now and try input those now.

It should return at least something, perhaps you mistyped?

Run cat /etc/default/grub and check the whole file.

Okay i typed that in and return a bunch of stuff so i input the parameters from what worked in the GRUB_CMDLINE_LINUX?

In grub you’ll find a line starting with kernel=, I was just giving you an example of where to place your options.

Okay so i input in the line that start with kernel=


Hold on, sorry mate I assumed those were kernel options but it’s not the case, these are grub configuration options, so they’re not gonna work in the kernel= line.

Can you paste the output of the following commands:

$ uname -r
$ cat /etc/default/grub
$ ls /boot | grep initr

This is correct way to do it. I can confirm these options are found in my grub too, but I doubt it has anything to do with your issue.