Dell OptiPlex 5040 UEFI Boot does not Find xen.efi

Can someone offer some insights into booting Qubes on a Dell OptiPlex 5040 desktop? The HCL shows some have had success with installing Qubes on the Dell OptiPlex series of computers. Not sure if this is a hardware issue specific to the 5040 computers or not.

The install appears to have created the correct files in the ESP but the computers setup displays the default backup path to:
\EFI\BOOT\BOOTX64.EFI
rather than to:
/EFI/qubes/xen.efi
Opening a console (Ctl-Alt-F2) and unning efibootmgr:
efibootmgr -v -c -u -L Qubes -l /EFI/qubes/xen.efi -d /dev/sda -p 1
“placeholder /mapbs /noexitboot”
set up the correct boot disk entry. But restarting the computer and opening setup revealed the ‘File System List:’ and “Filename:” entries were the same as for the Windows Boot Manager. For example the “Filename:” entry was reset to:
\EFI\BOOT\BOOTX64.EFI
Maybe someone familiar with over-riding the UEFI firmware settings could offer some ideas.

===== UPDATE ======

Qubes was successfully installed on the harddrive
Booted system without USB installation drive installed.
Selected F2 to open Setup
Deleted all Qubes boot drive entries.

Then rebooted system with usb installation drive installed.
CTL-ALT-F2 (Open console)
mkdir -p /mnt/sda1
mount /dev/sda1 /mnt/sda1 (ESP on my sys is /dev/sda1)
ls /mnt/sda1
EFI
mkdir /mnt/sda1/BOOT

Copied contents of the installed /EFI/qubes directory to /EFI/BOOT

cp -af /mnt/sda1/EFI/* /mnt/sda1/BOOT
cd /mnt/sda1/BOOT
cp xen.efi BOOTX64.efi
cp xen.cfg BOOTX64.cfg
efibootmgr -v -c -u -L Qubes -l /EFI/BOOT/BOOTX64.efi -d /dev/sda -p 1
“placeholder /mapbs /noexitboot”
reboot without usb installation drive installed.
Selected F2 to open setup

This is were the snag was:

Noticed that the setup changed the “Filename:” entry to:
\EFI\BOOT\BOOTX86.EFI
Changed to:
\EFI\BOOT\BOOTX64.EFI
Rebooted and the system booted from the harddisk.