Dell G15 5520

Remarks

OS

Download 4.1.1 rc1 and create bootable usb
Boot it and on Install qubes press 'e'
In line module2 add 'nouveau.modeset=0 rd.driver.blacklist=nouveau video=vega:off' to end on line and press F10
When graphic installer loads, install qubes as well as initial config and finally login to qubes
Attach network cable and update

Graphic card

dom0: sudo qubes-dom0-update gcc kmod grub2-tools perl-bignum make
untrusted: download https://ftp.qubes-os.org/repo/yum/r4.1/current-testing/dom0/fc32/rpm/kernel-devel-5.15.48-1.fc32.qubes.x86_64.rpm
untrusted: download driver at https://www.nvidia.com/en-us/geforce/drivers/
dom0: qvm-run -p untrusted 'cat kernel-devel-5.15.48-1.fc32.qubes.x86_64.rpm' > kernel-devel.rpm
dom0: qvm-run p untrusted 'cat /home/user/Downloads/NVIDIA-Linux-x86_64{version}.run' > NVIDIA-Linux-x86_64-{version}.run
dom0: dnf install kernel-devel.rpm
dom0: chmod +x NVIDIA-Linux-x86_64-{version}.run
dom0: ./NVIDIA-Linux-x86_64-{version}.run --ui=none --no-x-check --keep --extract-only
dom0: cd NVIDIA-Linux-x86_64-{version}/kernel/
dom0: make module IGNORE_XEN_PRESENCE=y CC=“gcc -DNV_VMAP_4_PRESENT -DNV_SIGNAL_STRUCT_RLIM”
dom0: sudo cp nvidia.ko > /lib/modules/{verzia kernela}/extra
dom0: echo 'blacklist nouveau' | tee -a /etc/modprobe.d/blacklist.conf
reboot and press 'e' on 'Qubes with xen'
in line module2 - remove nouveau.modeset=0 rd.driver.blacklist=nouveau video=vega:off and press F10
graphics should now run on nvidia
dom0: sudo vim /etc/sysconfig/grub and remove nouveau.modeset=0 rd.driver.blacklist=nouveau video=vega:off
dom0: sudo grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg
after reboot it should start with nvidia automatically

Optionally install newest kernel:

dom0: sudo qubes-dom0-update kernel-latest kernel-latest-devel
after reboot it should start with nvidia automatically with newest kernel (check uname -a)

Sound card:
with nvidia it should already work through hdmi
Intel sound card:
untrusted: git clone https://github.com/thesofproject/sof-bin
untrusted: tar -czf sof.tgz sof-bin/
dom0: qvm-run -p untrusted ‘cat /home/user/sof.tgz’ > sof.tgz
dom0: tar -xvf sof.tgz
dom0: mv /lib/firmware/intel/sof /lib/firmware/intel/sof-old
dom0: mv /lib/firmware/intel/sof-tplg /lib/firmware/intel/sof-tplg-old
dom0: cd sof-bin
dom0: vim install.sh and comment 2 lines where is rsync and repace wirh 3 lines of cp:

...
    #rsync -a "${path}"/sof*"$ver" "${FW_DEST}"/
    #rsync -a "${path}"/tools-"$ver"/ "${TOOLS_DEST}"/
    cp -r "${path}"/"$ver".x/sof-"$ver" "${FW_DEST}"/
    cp -r "${path}"/"$ver".x/sof-tplg-"$ver" "${FW_DEST}"/
    cp -r "${path}"/"$ver".x/tools-"$ver"/* "${TOOLS_DEST}"/
...

dom0: ./install.sh v2.0
reboot and sound should work. Click on speaker icon -> Audio mixer -> Output devices tab - there should be sof-hda-dsp, not Dummy.

Attachments

Sorry, new users can not upload attachments

2 Likes

You could just paste the content of the .yml file here.

1 Like

That’s actually the preferred solution.

  1. new users can do it
  2. other members can see the contents without downloading the file
  3. it’s less friction for me to process (clipboard instead of qvm-copy)

ok, so here we go:

---
layout:
  'hcl'
type:
  'notebook'
hvm:
  'yes'
iommu:
  'yes'
slat:
  'yes'
tpm:
  'unknown'
remap:
  'yes'
brand: |
  Dell Inc.
model: |
  Dell G15 5520
bios: |
  1.4.1
cpu: |
  12th Gen Intel(R) Core(TM) i7-12700H
cpu-short: |
  FIXME
chipset: |
  Intel Corporation Device [8086:4641] (rev 02)
chipset-short: |
  FIXME
gpu: |
  Intel Corporation Device [8086:46a6] (rev 0c)
  NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] [10de:2560] (rev a1) (prog-if 00 [VGA controller])
gpu-short: |
  FIXME
network: |
  Intel Corporation Device 51f0 (rev 01)
  Realtek Semiconductor Co., Ltd. Device 2600 (rev 21)
memory: |
  32452
scsi: |

usb: |
  3
versions:

- works:
    'FIXME:yes|no|partial'
  qubes: |
    R4.1
  xen: |
    4.14.5
  kernel: |
    5.16.18-2
  remark: |
    FIXME
  credit: |
    FIXAUTHOR
  link: |
    FIXLINK

---

I’ve got also cpio.gz, I tried to send it to qubes-users@googlegroups.com, but mail came back (We’re writing to let you know that the group you tried to contact (qubes-users) may not exist, or you may not have permission to post messages to the group.)

2 Likes

Thank you @siginigin for your HCL report, which is online now!

I’ve got also cpio.gz, I tried to send it to qubes-users@googlegroups.com, but mail came back
You need to be a member of the list to be able to send to it. However, the cpio info is really only needed when doing active troubleshooting/debugging with the developers. We don’t even have a central place to store them (except the mailing list). So no need to send it unless a developer requests it.

Thanks!

Hello, I had the same problem as you but this did not solve my problem. I can’t get a second screen. My HDMI port cannot be recognized.

Hi,

a friend of mine has exactly the same notebook and he managed to get the graphics working without these workarounds. The only thing he did was he disabled hybrid graphic mode in bios and the installer showed up as well as installation and starting installed qubes. He tried 4.1.1 and 4.1.1 rc1.

There was only one problem with sound card, but he used procedure mentioned above and now is everything working.

Does suspend work?