Debug: boot dom0 without Xen

Hello, when dom0 has finished booting and shows up the GUI login screen, it starts launching the domUs, which raises all my CPU to 100%. Even the serial console is unusable.
I know that sys-fw is the culprit because the 100% CPU usage is why I hard rebooted dom0.
So is there a Qubes way to deactivate a domain from starting on boot (or all of them) ? On my dom0 I have entries in GRUB to boot dom0 w/o Xen, so no domU can start, is it possible with Qubes/can I mimic it ?
By the way, the sys-net domain will autostart even if “Autostart on boot” is unchecked in the GUI (and IIRC the sys-fw too, I’m pretty sure I’ve set autostart to false). Is it a bug or by design ?

See Autostart troubleshooting | Qubes OS

Something depends on it apparently - maybe you have sys-whonix autostar, which is requires sys-firewall, which requires sys-net?

Damn sorry I missed that one, thanks it worked !
Shouldn’t it be in a GRUB rescue item though for easier access (think newcomers) ? Also browsing the forum I read a few people had problems after updating their kernels, which prevented them from booting.
I don’t know how it’s handled on Qubes/fedora yet, but with Xen on Debian, when there is a kernel update, the GRUB entries get doubled, so you get 4 boot options on next boot: Xen+current working kernel, Xen+new kernel, current working kernel w/o Xen, new kernel w/o Xen. This is handy, and more forgiving for new users and experimenters ! ^^

Exactly ! The sys-fw was set on autostart but as it was in PVH, it always crashed before I could see it starting and thought it wasn’t set as autostart >.<. But the dependency was effecitvely set, so sys-net started automatically nevertheless !
Two questions :

  • shouldn’t the “Autostart on boot” be greyed out when other domUs require it (à-la warning next to template or next qube) ?
  • when changing settings via the Qube manager, are they written immediately to disk or is it done at a later time ?

Thanks again !