Debian Update

Debian 10 will not update in the Qubes updater. Should I go to my debian terminal and

sudo apt update && sudo apt upgrade -y

I think I read somewhere not to do that but to always update using the qubes update tool.

Do you have some errors in Qubes updater or it just don’t find any updates available?

Error on updating debian-10: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’,–targets=debian-10’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’] returned non-zero exit status 20

Not sure how to find this information.

Run this command in your updatevm:
dig qubes-os.org
or
ping qubes-os.org
Also copy the full Qubes updater log, maybe it’s a different issue.

Maybe I am dumb as a box of rocks but, all I know about the qubes updater is to click the button on my screen and hit start and finish. I cannot figure out how to run the updater in a terminal and I cannot copy and paste the output from the updater using ctrl+sh+c ctrl+sh+v
I do not know how to run dig qubes-os.org in the updatevm and if I try that command in terminal I get “command not found.” I have been looking through related post but so far I am stuck on I don’t know what to do.

I would love to show you my logs but I do not know where they are.

Click on the Global Clipboard widget in the tray and you can copy dom0 clipboard to global clipboard by clicking on “Copy dom0 clipboard”.

First determine what is your updatevm. Paste here the output of this command in dom0 terminal:
cat /etc/qubes-rpc/policy/qubes.UpdatesProxy

cat /etc/qubes-rpc/policy/qubes.UpdatesProxy
$type:TemplateVM $default allow,target=sys-whonix
## Note that policy parsing stops at the first match,
## so adding anything below "$anyvm $anyvm action" line will have no effect

## Please use a single # to start your custom comments

# Upgrade all TemplateVMs through sys-whonix.
#$type:TemplateVM $default allow,target=sys-whonix

# Upgrade Whonix TemplateVMs through sys-whonix.
$tag:whonix-updatevm $default allow,target=sys-whonix

# Deny Whonix TemplateVMs using UpdatesProxy of any other VM.
$tag:whonix-updatevm $anyvm deny

# Default rule for all TemplateVMs - direct the connection to sys-net
$type:TemplateVM $default allow,target=sys-net

$anyvm $anyvm deny
[Tommy@dom0 ~]$ $ cat /etc/qubes-rpc/policy/qubes.UpdatesProxy
bash: $: command not found
[Tommy@dom0 ~]$ $type:TemplateVM $default allow,target=sys-whonix
bash: :TemplateVM: command not found
[Tommy@dom0 ~]$ ## Note that policy parsing stops at the first match,
[Tommy@dom0 ~]$ ## so adding anything below "$anyvm $anyvm action" line will have no effect
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ ## Please use a single # to start your custom comments
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ # Upgrade all TemplateVMs through sys-whonix.
[Tommy@dom0 ~]$ #$type:TemplateVM $default allow,target=sys-whonix
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ # Upgrade Whonix TemplateVMs through sys-whonix.
[Tommy@dom0 ~]$ $tag:whonix-updatevm $default allow,target=sys-whonix
bash: :whonix-updatevm: command not found
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ # Deny Whonix TemplateVMs using UpdatesProxy of any other VM.
[Tommy@dom0 ~]$ $tag:whonix-updatevm $anyvm deny
bash: :whonix-updatevm: command not found
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ # Default rule for all TemplateVMs - direct the connection to sys-net
[Tommy@dom0 ~]$ $type:TemplateVM $default allow,target=sys-net
bash: :TemplateVM: command not found
[Tommy@dom0 ~]$ 
[Tommy@dom0 ~]$ $anyvm $anyvm deny
bash: deny: command not found

Edit: text formatted by @ludovic

Ok so your updatevm is sys-net.
Can you also copy the full Qubes updater log to see what exact errors are you getting?

I am looking at the updater but I cannot copy or paste anything from it that log must be in /etc somewhere right.

You can select the text in the Qubes updater and copy it with Ctrl+C.

Updating debian-10

Error on updating debian-10: Command ‘[‘sudo’, ‘qubesctl’, ‘–skip-dom0’, ‘–targets=debian-10’, ‘–show-output’, ‘state.sls’, ‘update.qubes-vm’]’ returned non-zero exit status 20
debian-10:

        ID: apt-get update --allow-releaseinfo-change
  Function: cmd.run
    Result: False
   Comment: Command "apt-get update --allow-releaseinfo-change" run
   Started: 13:26:13.648869
  Duration: 2677.821 ms
   Changes:   
            ----------
            pid:
                5644
            retcode:
                100
            stderr:
                W: GPG error: https://download.docker.com/linux/debian buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8
                E: The repository 'https://download.docker.com/linux/debian buster InRelease' is not signed.
            stdout:
                Hit:1 https://deb.qubes-os.org/r4.0/vm buster InRelease
                Hit:2 https://deb.debian.org/debian buster InRelease
                Get:3 https://download.docker.com/linux/debian buster InRelease [54.0 kB]
                Err:3 https://download.docker.com/linux/debian buster InRelease
                  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8
                Hit:4 https://deb.debian.org/debian-security buster/updates InRelease
                Reading package lists...

        ID: update
  Function: pkg.uptodate
    Result: False
   Comment: W: GPG error: https://download.docker.com/linux/debian buster InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8
            E: The repository 'https://download.docker.com/linux/debian buster InRelease' is not signed.
   Started: 13:26:17.003922
  Duration: 2389.873 ms
   Changes:   

        ID: notify-updates
  Function: cmd.run
      Name: /usr/lib/qubes/upgrades-status-notify
    Result: False
   Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
   Started: 13:26:19.394009
  Duration: 2565.565 ms
   Changes:   
            ----------
            pid:
                6406
            retcode:
                100
            stderr:
            stdout:

Summary for debian-10

Succeeded: 0 (changed=2)
Failed: 3

Total states run: 3
Total run time: 7.633 s

I need to work on my copying and pasting skills in qubes.
The global clipboard actually tells you what to do I am just to hardheaded to pay attention I guess. Must be why the 3rd grade was the hardest 3 years of my life, I cannot follow directions. :flushed:

You have a problem with your docker repository because you’re missing it’s public key.
Run this command in debian-10 template to add it:
curl --proxy http://127.0.0.1:8082 -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -
Then shutdown the template and try to update again.

Hum bash: curl: command not found

curl --proxy http://127.0.0.1:8082 -fsSL https://download.docker.com/linux/debian/gpg | sudo apt-key add -
bash: curl: command not found
gpg: no valid OpenPGP data found.

wget "https://download.docker.com/linux/debian/gpg" -e use_proxy=on -e https_proxy=127.0.0.1:8082 -O- | sudo apt-key add -
wget "https://download.docker.com/linux/debian/gpg" -e use_proxy=on -e https_proxy=127.0.0.1:8082 -0- | sudo apt-key add -