Debian update broke Internet connectivity in sys-net?

Hi. I run a Disposable sys-net based on Debian. 4.1 has been running smoothly for months. I ran today the most recent updates and later shutdown my lapotp. When I turned on my laptop, I was no longer able to get sys-net to channel internet through. I was still able to access the router interface, but no Internet came in through ethernet or wifi. I ran some tests, shutdown all Qubes and relaunched the Qubes and tried again, attempted to run the Internet through sys-usb via a USB ethernet, etc. I failed. Then I switched the Template for the Disposable sys-net to Fedora-35, and everything ran normally again. Internet came through.

What was the problem?

Maybe it was a problem with DNS?
When you checked the internet connection did you only try to access it using domain names? Or you’ve tried to use IP as well like ping

I didn’t try using an IP as this is not something I fully understand. Since I didn’t change anything in my system, could a Qubes update modify DNS settings? I will test use IP later.

Not sure what could’ve broken after the update. Maybe you have some specific DNS configuration and not just getting DNS from your router with DHCP and some package or config was broken/rewritten after update.

Update / problem disappeared: I reverted back to the original Debian setup for sys-net to do some additional testing. And it worked normally again without any action from my side. I don’t know what had happened. The problem earlier had survived several restarts of Qubes, and several restarts of sys-net. But now it’s gone. :man_shrugging: