Debian netinst -> unreachable gateway

I am a relatively new Qubes user on release 4.2.1. I attempted to make a new standalone qube with HVM virtualization installed from a debian netinst.iso. In the configure network dialog I entered the IP, netmask and gateway with values taken from the Qube Manager settings dialog for the new qube but I get the error “unreachable gateway”. Any thoughts or pointers to where I can learn what I might do to make this work?

My goal is to make a minimal install sufficient to run a handful of applications distributed as .appimage files where I can easily use the latest stable build and one or more unstable development builds. Apps such as openscad, freecad, orcaslicer, prusaslicer, etc. My desire is to have a qube which starts the debian desktop where I put all the .appimages giving me convenient access to them without having to maintain .desktop files and the dom0 app menu or desktop. Also I am hoping that orcaslicer might work correctly this way. Running it under PVH virt mode qubes based on the standard fedora and debian templates there is a problem where all drop down dialogs when opened by mouse click instantly close. Please explain if my above attempted qube setup is a poor choice for my intended use.

Set netmask to

You won’t have the Qubes OS integration this way, e.g. you wont be able to copy files to/from this qube.
You can use Qubes OS debian template in full desktop mode:

Thanks apparatus I will soon test this and follow up.

Setting netmask to worked! Thanks for the tip and the additional discussion on using the standard templates with their full desktop.

Curiously the net config dialog then prefilled gateway with a different value from the one in the qube’s setting dialog and the prefill did not work but using the gateway value from the setting dialog did work. I completed the setup and got a working VM with its own desktop. The lack of integration for file copy and cut/paste with other qubes is ok as USB device mounting worked and for the very limited amount of transfers I might need that would suffice.

But display resolution was limited to 1920x1280. Even if it is possible to fix that and use my monitor’s max resolution the updates were hideously slow and choppy so this approach is not looking promising for me.

Running a VM with the full desktop after installing from an .iso file did fix the issue wiith OrcaSlicer and the similar Bambu Studio where mouse left clicking on a drop down dialog would cause it to open and instantly close in any standard template based VM.

how to copy and paste then? can it accept usb maybe and then to copy to usb and then to whatever the destination is or what are the alternatives here please?

You still can transfer files to/from this qube using Qubes OS integration, so no need for USB.

I mean like in general if I have a standalone with OS that Qubes don’t have integration with… would I still have the ability to use the usb tho?

Yes, you can attach USB devices without Qubes OS agents installed.
But you need to enable the stubdom-qrexec feature to be able to do it.
You need to run this command in dom0:

qvm-features yourVMname stubdom-qrexec 1
1 Like

Ah… thanks!