Debian Bookworm package list incomplete in R4.2?

I just started upgrading to R4.2 and ran into a “no installation candidate” error when attempting to apt install qubes-core-agent-networking in the debian-12-minimal template. The package exists at the following location

Index of /r4.2/vm/pool/main/q/qubes-core-agent/

but does not have an entry in the following package list:

I’d prefer to install this single package, rather than install the meta package qubes-vm-recommended, which includes qubes-core-agent-networking as a dependency. So how do I get past the apt error?

This should be fixed already since few hours.


I manually verified that the package was on the list, updated the template, and tried to install, but received the same error. apt list | grep qubes-core-agent, only listed a single package. So I checked the package list again and the entry was no longer there. very strange

Have you called apt update (if you did template update manually)?

I tried both qubes update and apt update in the template. In each case apt list does not show qubes-core-agent-x for any package x. Downloading the package list from the browser, I no longer see qubes-core-agent-networking included in the list, which was last posted 15-Mar-2024 12:16.

All good now. Thanks for the quick fix and for all of your hard work! Also, I’m enjoying the new UI, specifically thank Marta and team for the upgrade. Much appreciated!