Debian 12 templates available

The following new templates are now available:

Qube OS 4.1

Qubes OS 4.2-rc1

There are two ways to upgrade your template to a new Debian release:

For a complete list of template releases that are supported for your specific Qubes release, see our supported template releases. Please note that no user action is required regarding the OS version in dom0 (see our note on dom0 and EOL).

This is a companion discussion topic for the original entry at

when I try to install a fresh debian-12-minimal template in r4.1 I receive a template not found error.

Indeed, looks like we forgot to migrate these from testing to stable. Sorry about that. Reopened issue:

1 Like

The packages have been migrated.

1 Like

I am getting “Error canonicalizing file: failed to fill whole buffer” error, when I try to download debian-12-minimal template.

Likewise, same error for both debian-12 and debian-12-minimal.

Will debian-12-xfce be released for Qubes 4.1 or the decision hasn’t been made yet?

Noted on the issue. Thank you.

See the answer here.

Hmm, I think 4.1 doesn’t retry download from alternative mirrors, and the first one on the list ( hasn’t fetched the package yet. I think it should appear there about 22:00 UTC…
Alternatively, you can edit /etc/qubes/repo-templates/qubes-templates.repo in dom0 and temporarily comment out metalink= entry and uncomment the baseurl= one

1 Like

That worked, thanks.

Another issue I’ve run into while upgrading my templates is that the qubes-contrib repo is missing for bookworm in r4.1. There is a bookworm-testing repo for r4.2.

@fepitre are contrib packages planned for r4.1 bookworm?

I’ve noticed that /etc/apt/sources.list.d/qubes-r4.list once again uses tor+http for Tor repositories. However, if you uncomment those apt will give an error:

E: The method driver /usr/lib/apt/methods/tor+http could not be found.
N: Is the package apt-transport-tor installed?

Since Tor is done by the Whonix qube, shouldn’t the default be http instead of tor+http?

At first not, but I’ve enabled it and started building some of them.

Well, now I get to see if my minimal template management stuff will work as well as I hoped it would when “upgrading” templates.

I’m not going to upgrade the templates; I’m going to generate a parallel set. Their names all begin with deb11*, the new set will obviously start with deb13*. (Just kidding: deb12*, actually.)

[I’ve already found one thing I don’t like about the way it works.]

Well I am using deiban-12 minimal right now. (I cloned it and installed firefox, on a new template, which is the template for this VM.) Should be pretty good if this works, though I have one other use case that’s pretty likely to break if anything will.

REMINDER: this is from using it directly rather than trying to upgrade a deb-11-minimal based template to debian 12.

NOTE: Nevermind, I figured this one out. It’s trying to somehow unpack debian-12 onto dom0 somehow, and there wasn’t enough space. I still want to expand it. It turns out the lion’s share of dom0 is filled with all the stuff that comes with kernels. I have to figure out which ones I can delete and how to do it. Anyhow, for posterity I have not altered the original text of this comment, which starts…NOW:

In trying to get debian-12 (not minimal), I get the following. It is downloading just fine. This is some sort of install glitch.

Installing template 'debian-12'...
tar: ./var/lib/qubes/vm-templates/debian-12/root.img.part.05: Wrote only 512 of 10240 bytes
tar: ./var/lib/qubes/vm-templates/debian-12/vm-whitelisted-appmenus.list: Cannot write: No space left on device
tar: ./var/lib/qubes/vm-templates/debian-12/whitelisted-appmenus.list: Cannot write: No space left on device
tar: Exiting with failure status due to previous errors
ERROR: Failed to extract debian-12 template

qui-disk-space seems to think I have a LOT of space left–in vmpool (less than 100GiB out of well over 300 GiB used). On the other hand, varlibqubes is at 13.9 Gib out of 19.5 GiB. That could be the issue since debian-11 takes up about 6.4 GiB I would imagine debian-12 does too.

How do I expand varlibqubes?