Debian 12 Bookworm unable to install xen-utils-guest

I’ve noticed some folks have managed to install debian 12 bookworm template. However I am running into an issue

Preparing to unpack …/xen-utils-guest_4.14.5-19+deb12u1_amd64.deb …
Unpacking xen-utils-guest (4.14.5-19+deb12u1) …
dpkg: error processing archive /var/cache/apt/archives/xen-utils-guest_4.14.5-19
+deb12u1_amd64.deb (–unpack):
trying to overwrite ‘/lib/systemd/system/xendriverdomain.service’, which is als
o in package xen-utils-common 2001:4.8.5-42+deb11u1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Is this just do to the fact that Debian 12 isn’t ready yet for Qubes 4.1.2 or did I screw up on a step?

Many Thanks.

Have you enabled current-testing for bookworm because there is GitHub - QubesOS/qubes-vmm-xen-guest: Minimal xen (meta) package to install inside domU which I think should solve your problem.

1 Like

Why is “xen-utils-common” installed in the domU ? This is only for dom0s.
apt info xen-utils-common: This package is only required on the host system (Domain 0) and not on the virtual guest systems (Domain U).

You can try removing “xen-utils-common”, or am I missing something ?

I probably went about this the wrong way. I cloned the debian 11 template and then in the clone I ran the following:

sed -i ‘s/#deb [arch=amd64] bullseye-testing main/deb [arch=amd64] bullseye-testing main/g’ /etc/apt/sources.list.d/qubes-r4.list
sed -i ‘s/#deb [arch=amd64] bullseye-securitytesting main/deb [arch=amd64] bullseye-securitytesting main/g’ /etc/apt/sources.list.d/qubes-r4.list
apt update && apt upgrade -y && apt autoremove -y
sed -i ‘s/non-free/non-free non-free-firmware/g’ /etc/apt/sources.list
sed -i ‘s/bullseye/bookworm/g’ /etc/apt/sources.list
sed -i ‘s/bullseye/bookworm/g’ /etc/apt/sources.list.d/qubes-r4.list
apt full-upgrade -y && apt autoremove -y

I’m guessing a I went about this wrong and should have used the qubes builder process?

Dumb remark: are you sure the 1st two seds worked ? You used “/” as a pattern separator, but it is present in patterns. Use “!” or “|” ?

Your update steps miss an “apt update” AFTER the sources changes.
Also, to ensure better upgrade path, you should use “apt upgrade --without-new-pkgs” before doing the “full-upgrade”.


  • apt update && apt dist-upgrade -y && apt autoremove -y
  • edit sources
  • apt update && apt upgrade --without-new-pkgs && apt full-upgrade

EDIT (PS: hasn’t the syntax evolved in sources.list between bullseye and bookworm ?)

Yeah they worked. I just pasted them incorrectly somehow in the forum post.

Anywho, it seems your suggestions worked for me as far as I can see, so thanks very much for that! Greatly appreciate it!.

1 Like