Debian-11 templates available for 4.0

There are Debian-11 and 11-minimal templates available in the
qubes-templates-itl-testing repository.

Please check that the bullseye template is a drop in replacement for
buster, and that all tools and processes work as expected, including the
Qubes Updater.
It would also be useful if you could clone a debian-10 and perform an in
place upgrade to bullseye, and confirm that full functionality is
present.

If you have time to test the minimal template, and its use as basis for
the various sys-qubes, that would be awesome.

Look forward to hearing from you, with any comments, good or bad.

3 Likes

I’ve been testing qubes-template-debian-11-4.0.6-202109010214 and debian-12 (in-place upgraded).

  • The transition to the new templates has been surprisingly smooth, ran into no issues at all. My sys-firewall, sys-net, sys-usb, disposable VMs all work fine after flipping the template to debian-11 from debian-10, and my AppVMs work with debian-12.
  • qubes-update-gui can upgrade both debian-11 and debian-12 templates, with a mgmt-vm based on debian-11 (but not debian-10)
  • In the procedure for disabling passwordless sudo, the suggested edit to /etc/sudoers.d/qubes probably should be rephrased since the top of that file has changed.
1 Like

@unman requested:

It would also be useful if you could clone a debian-10 and perform an in place upgrade to bullseye, and confirm that full functionality is present.

There is a small issue with the debian-security repo URL and the instructions on the website. I submitted a pull request to address it and request you as reviewer.

If you have time to test the minimal template, and its use as basis for the various sys-qubes, that would be awesome.

All my templates are debian-minimal and have successfully been in-place upgraded to bullseye. My only issues have been with Java-8 JRE update being incompatible with a particular app I use and my respective “update-alternatives” config being overwritten. But that is hardly a Qubes OS nor a Debian issue.

One week in I still see no issues. Also using debian 11 as sys- qubes.

1 Like

The only issue I have seen is that 11 seems to require a little more
memory than 10. Qubes where I had heavily restricted the memory would
not start when switched to a debian-11 template until I allocated a
little more memory.
That’s a real edge case: perhaps worth a comment in the release notes,
although that’s not recommended usage.

Otherwise everything seems fine, both with 4.0 and 4,1.

1 Like