Debian 11 minimal template: Some GTK package is missing for application

Let’s take audacious (music player) as an example:

apt install audacious

On Debian 11 minimal template it looks like:

, whereas Debian 11 full shows:

The package requires libgtk dependencies, I can start and use it as usual.

Hence, is this some problem related to a missing default GTK theme? Tried some Qubes helper packages and some GTK ones, without effect.

1 Like

You can try collecting the installed packages on debian-11 distro into a text file:
(in debian-11 template) $ apt list --installed > debian-11-packs
and then do the same with your current debian-11-minimal one:
(in debian-11-minimal template) $ apt list --installed > debian-11-min-packs

and then either inspect the contents of these two files, or copy these two files into a qube and run a diff command on them:

$ diff debian-11-packs debian-11-min-packs

That way, you can see which packages are absent in the minimal qube, and then install the related ones to your issue.

2 Likes

This is useful, thanks!

I just use the vanilla templates + audacious. In the diff are very few packages with gtk substring, which I then have installed.

diff-with-gtk.txt:

emacs-gtk
gir1.2-gtksource-4
gstreamer1.0-gtk3
libcanberra-gtk3-0
libcanberra-gtk3-module
libdbusmenu-gtk3-4
libgtksourceview-4-0
libgtksourceview-4-common
libgtk2.0-0
libgtk2.0-bin
libgtk2.0-common
xargs -a diff-with-gtk.txt apt install

Other tried packages:

 gnome-accessibility-themes
 gnome-themes-extra-data
 gnome-themes-extra
 gnome-themes-standard

Still theres something missing. It’s likely something specific about GTK, as under Appearance → Interface → GTK Interface is enabled.

Need to try out some more ones…

Possibly unrelated, but when I install GIMP [edit: on a deb11 minimal-derived template] most of the buttons used by the app don’t have icons on them. So I’m faced with toolbars full of Xs. [These are even less useful than the doodles on Micro$haft’s never-to-be-sufficiently-damned “ribbons” (at home I refuse to move past office 2003).]

Why GIMP doesn’t come with its own icons is a mystery to me, but I have no idea how to even BEGIN to figure out what to install to fix this. Googling leads me to people complaining about no link to GIMP or no critter GIMP icon for the app itself, not about the button graphics being gone.

Weird. Gimp works fines for me from debian-11-minimal.

I thought to check on something. I’m installing it with --no-install-recommends.

If I don’t add that flag, it works.

That tells me that something on the recommended list should be mandatory.

[edit: would this possibly be useful for the original issue?]

If you apt info audacious, it shows unzip as recommended package, so I guess that’s not needed here.

And judging by the screenshots, it (for me) strongly hints in direction to missing theme/layouts/GTK, not missing icons or fonts.

Duh, I must have missed something.

OK, here is another GTK-related issue with vim-gtk, xterm and debian-11-minimal:

Inserted characters are still displayed on screen despite after having deleted them, e.g. with x in normal mode.

vim on debian-11: works
vim-gtk on debian-11: works
vim on debian-11-minimal: works
vim-gtk on debian-11-minimal: does not work
(all vanilla templates)

UTF8 encoding is set both in xterm and vim, which is a solution from other search results.

A central Qubes OS contrib resource for how to install specific apps in minimal templates would be very helpful, wouldn’t it?