Debian-11-minimal: Some Languages cannot be shown in any application s

Hi everyone. It is the sixth day after install Qubes in my machine.

After installed debian minimal template, I found that some of the languages are not able to shown in any applications including browser, file manager, etc…(What I noticed are Japanese and Chinese).

I considered that is the problem of encoding or locale settings, and I ran the commands:

dpkg-reconfigure locale

And selected all-locales, then rebooted.

However it doesn’t work, then I tried another method:

sudo apt install locales-all

Apparently it doesn’t works neither. It just show some squares like [], same as before.

Am I do something wrong about that? Because the “stock” debian template works with that. If yes, what should I do?

I believe it’s font related, try apt install fonts-noto

1 Like

Thank you! It shows the words perfectly now! I want to ask one more question: If I added a keyboard layout (let say: Greek) in dom0, will it still able to type Greek on other VMs?

I never test it so i don’t know :rofl:

It’s okay, I will try to figure it out, thanks for your support!