Debian-11-minimal ... permission issue with webcam and USB audio

I solved this before but forgot. The problem:

  • debian-11-minimal with …

    • qubes-core-agent-passwordless-root
    • qubes-app-shutdown-idle
    • qubes-core-agent-networking
    • pulseaudio-qubes
    • curl
    • nautilus
    • qubes-core-agent-nautilus
    • zenity
    • brave-browser
    • libnspr4
    • libnss3
    • libxss1
    • qubes-usb-proxy
    • unzip
    • teams
  • lsusb shows …

Bus 003 Device 002: ID 046d:0893 Logitech, Inc. Logitech StreamCam
Bus 002 Device 002: ID 046d:0ab7 Logitech, Inc. Blue Microphones

… among others.

  • 1 of my 4 USB controllers is assigned to this qube and the cam and mic are plugged in

  • teams can’t see the cam nor the mic

  • I know this is a permission issue, because adding ‘user’ to the group ‘video’ makes the cam work

… of course I could now figure out how to do something similar for the mic, but I am pretty sure I solved this previously by installing a packet. Either something with “usb” and “av” in it or maybe something with “dbus”. I am searching and trying four hours now, so I hope maybe someone in the forum knows and can give me a hint.

This shows the importance of documenting your Qubes system.
If you use salt, then you have a self-documenting setup which you can
easily transfer to another system, or pass to another user.

1 Like

I fully agree and do have bash files for this (instead of salt formula).

Rebuilding all my templates under R4.1 was a matter of minutes. But it appears I have fallen short and not documented this one change in my scripts.

The solution for this particular issue is:

sudo usermod -a -G video user
sudo usermod -a -G audio user

… in the template. There might be other ways to solve this, but the above works and frankly looks like the intended way to make it work.

1 Like