Debian-11 Disposable VM doesn't see provided PCI devices


I’ve just created a new app qube (debian-11-dvm) base on a default debian-11 template. Also I checked a mark “Advanced->Disposable template” and now I got a disposable vm.

I entered “Devices” tab at settings and selected several PCI devices I want to have access to inside the dvm. Changed virtualization mode to HVM because saw a notice that PVH mode doesn’t support PCI Passthrough.

I run xterm inside that disposable vm and found that there is no any pci device I selected.

I’ve done the same steps for a template VM (default debian-11) and everything works well. I got access to several PCI devices I chose.

Is PCI passthrough doesn’t work for disposable vm or it’s just my mistake somewhere?



PCI devices – nvme drives.

The devices need to be attached to the final vm, in this case a disposable vm. The way you explained your configurations, makes it seems like the pci devices are accessible from debian-11-dvm.

Instead, you may want to create a named disposable (such as sys-net) and attach the pci devices there.

Make sure the qubes-usb-proxy package is installed.

I have two qubes.

  1. debian-11 (qube type – template).
  2. debian-11-dvm which uses debian-11 as a template. (qube type – app).

pci drives are accessible from debian-11 qube.
I can start xterm using debian-11 qube and check their existence.

but with the same configuration (which is used for debian-11) they are not accessible for debian-11-dvm.

I’ve tried to add drives to both of them. To one of them. Doesn’t work.

I’ll check the qubes-usb-proxy package.


I’ve just created a new qube (type=app) which uses a debian-11 as a template.
PCI devices are accessible in the qube.

Also, I found that I had created a disposable template and now I can create a disposable qube which can use that disposable template as a template.

I’m testing it.

UPD 2.

I’ve created a new disposable qube debian-11-dvm-not-template which uses debian-11-dvm as a template.

PCI devices are accessible. Everything is fine!

I don’t really understand why they were not accessible via that debian-11-dvm disposable template so if anyone would be so kind to explain it to me I’d be glad to hear!

Also I don’t understand why there are only disposable vm templates (for whonix and debin/fedora) in base installation. Why do I need to create a disposable VM based on a disposable vm template? What is the point?

OS is freaking awesome. Need to look deeper.

UPD 3.

Ohh, I got it. Menu element Disposable: fedora-36-dvm and similar can create a disposable qube dynamically. Basing on a template (which fedora-36-dvm is).

okay, then the main point is dynamically created qube doesn’t inherit devices settings which template had.

absolutelly logic and fantastic. no question anymore.


P.S: also the main advantage of using template is that I can create anything for example in user’s home directory and then reuse it in disposable qubes. cool!

question is solved.
akismet deleted my message, I hope mods’ll restore it soon.
it’s fully detailed =)