Debian 11 Dependency Problem

Debian 11 Dependency Problem

I tried to switch from Debian 10 to 11. Sadly, there is a problem with dependencies. I guess it is an upstream Debian 11 problem. I am not 100% sure. Even if it is an upstream problem it should be fixed.

Problem: Dependency “libappindicator1” is not included. Affected programs (many) like Wire Messenger, Keybase and LBRY.

  1. Will this be fixed by QubesOS or is it an upstream problem?
  2. I guess this is the fix: apt - Missing libappindicator1 - Unix & Linux Stack Exchange

I’m running Wire in Debian 11.

Did you try sudo apt --fix-missing update (after updating with missing dependencies)?

Or sudo apt install -f (after installing a package with missing dependencies)?

Yes, the package is not available for Debian 11. Read the Link.

This isn’t helpful.
How did you install it?
How did you cover the missing dependency?


  1. It’s an upstream problem for Wire, and those other applications.
    libappindicator1 is removed from Debian after Debian-10 - there has been
    plenty of warning. It’s not in sid and it wont be coming back.
    There are many alternatives.

  2. The obvious fix is to repackage Wire to not require that package.
    You could also try using the package from Debian-10, which sometimes
    works in this sort of case.
    Check out to find the package - you’ll need
    libindicator7 and libappindicator1 - pull those in to your template and
    manually install using apt install
    I suggest doing this in a clone of your template to avoid breakage.
    It may or may not work.

Until @necker provides more helpful reply, that may be your best

I never presume to speak for the Qubes team.
When I comment in the Forum or in the mailing lists I speak for myself.

Thanks @unman. I can see that wasn’t helpful for @wilsonb

I misremembered how I got Wire working in Debian 11. I was initially thinking of my VeraCrypt install which had dependency issues that were easily fixed with the commands I mentioned.

For Wire, I now recall I had problems getting apt-key working so I opted to use the AppImage installer provided at AppImage doesn’t require dependencies and I was easily able to get Wire up and running.

I know this doesn’t address the issue of the libappindicator1 dependency in Debian 11 but it did address the general dependency problem of getting Wire running in Debian 11.

Also, fwiw, I continue to have problems getting Wire to retain certain settings with this install. The app launches at boot and keeps me logged in across sessions but I have to reset my preference for Dark mode every time I start the VM which is tedious but tolerable.

1 Like

@necker Thanks for the sensible reply and the suggested solution.
Cant help with the loss of preferences, I’m afraid.

1 Like

So the app devs have to repackage? Why was the dependency removed? It seems odd to me that they don’t care to fix the problem fro Debian 11.

I resolved this by installing Gnome Tweak Tools in the template. Then in the appVM I opened “Tweaks” from the VM app menu and chose the Dark Theme in the Appearance tab.

Then I opened the appVM Terminal and used
sudo nano ~./config/gtk-3.0/settings.ini
sudo nano ~./config/gtk-4.0/settings.ini

to each include:


Then I restarted Wire and the dark theme setting within the Wire options now persists. Apparently the Wire app is using the Debian system dark setting when configuring preferences and Gnome Tweak Tools is needed for Debian VMs to have a dark theme. Not sure why it worked at all before - but now it persists between boots.