[debian-10] update error: "Value 'stable' is invalid"

I searched this error before posting because I thought it may have happened to other people, but weirdly I haven’t found a single user sharing the same issue.

I’ve been using the Qubes Updater religiously, so everything was fine until now. No weird configurations.
But what surprises me is that every single Debian-10 template and Stand alone VM is now crapping out at the same time. So I am quite puzzled.

The error I am getting is the following:

user@debian-10:~$ sudo apt upgrade
Reading package lists... Done
E: The value 'stable' is invalid for APT::Default-Release as such a release is not available in the sources

Does anyone have a clue of what might be happening?
I am using Qubes R4.0.

Thank you in advance!

Most likely it’s because we have a new “stable” now (Debian 11):

You could replace “stable” by “buster” or “oldstable” in your Debian 10 TemplateVM.

You can also upgrade your Debian 10 VM to Debian 11. I haven’t tried it with Buster yet, but I have upgraded 9 → 10 in the past and it was surprisingly smooth.

1 Like

Where exactly can I replace this? I have exactly the same problem :woozy_face:

I have one qube using the Debian testing repo that led me to this same error. I solved it by editing a single file:

  1. Enter sudo nano /etc/apt/apt.conf.d/90default-release (or use editor of your choice)

  2. You should see APT::Default-Release "stable";

  3. Replace ‘stable’ with ‘buster’ (since it’s Debian 10)

  4. Save and exit

Edit: Filename might not be 90default-release in your setup; you might have to grep around.

 


Not technically trained; consume with salt; corrections appreciated

3 Likes

I’m more interested in how that entry might have got there in the
first place, because it isn’t present (by design) in the templates that
Qubes provides. But OP said “No weird configurations”?

Also, (and I say this repeatedly), many problems that users have are
not Qubes specific. This is one.
Searching for that error message (with or without “Debian” ) will bring
you to many reports, and solutions. The only Qubes specific part of the
solution would be in making any needed change in the template.

2 Likes

Well, as far as I remember, my debian-10 template was upgraded from a debian-9 template.
Using the instructions here:

So I thought it was relevant to share it in the forums, as well as trying to figure out if this sudden misconfiguration was qubes related.
I even stopped using apt-get within the templates a while ago, switching to Qubes Updater in the remote case I would be effing up something.

Are we supposed to make the upgrade to Debian 11?

Tried it yesterday on my Debian 10 TemplateVMs (a clean minimal template, and one with a bunch of apps). Everything works great so far!

Note that there are Debian 11 TemplateVMs available in itl-testing, but there’s no minimal template available yet.

1 Like

Hi, do you remember if you were using the debian-10 templates or if you upgraded from an existing Debian-9 to Debian-10?
Maybe that’s the cause of this?

I may test it later on by downloading a debian-9 template and upgrading it to debian-10 to see if it changes it to ‘stable’. If this is the reason, we can at least warn people about this in the "How to upgrade a Debian template in-place" guide

I was using Debian-10 templates. I have a Qubes 4.1 installation and I think 4.1 repos don’t have Debian 9 any more.

You might be right – this might be something that’s fixed either in the Debian 10 templates, but probably was an issue in Debian-9 and persisted after 9 → 10 upgrade.

It wasnt included in Debian-9 templates, and I dont think it was ever
included in the upgrade instructions.

I’m also curious about this. I haven’t seen this when performing routine updates of my Debian 10 templates.

@unman @adw In my case I changed the file when installing Wireguard since it needed the testing repo, which meant I had to add the testing repo and set the default repo to ‘stable’.

@qubito I started with a fresh d-10-minimal template

I have what seems to be the same issue, but in Qubes Updater. Would the apt.conf.d solution offered above be relevant for me as well? Here are the details provided in the Updater GUI:

Updating debian-10

Error on updating debian-10: Command '['sudo', 'qubesctl', '--skip-dom0', '--targets=debian-10', '--show-output', 'state.sls', 'update.qubes-vm']' returned non-zero exit status 20
debian-10:
  ----------
            ID: update
      Function: pkg.uptodate
        Result: False
       Comment: E: Repository 'https://deb.debian.org/debian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
                E: Repository 'https://deb.debian.org/debian-security buster/updates InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
       Started: 15:06:03.169137
      Duration: 6662.228 ms
       Changes:   
  ----------
            ID: notify-updates
      Function: cmd.run
          Name: /usr/lib/qubes/upgrades-status-notify
        Result: False
       Comment: Command "/usr/lib/qubes/upgrades-status-notify" run
       Started: 15:06:09.836288
      Duration: 4209.643 ms
       Changes:   
                ----------
                pid:
                    1322
                retcode:
                    100
                stderr:
                stdout:
...

It should be.

No, this is an entirely separate issue - the apt.conf.d setting
discussed will not resolve this, and would be inappropriate.

What has happened is this:
Bullseye, (Debian-11), has been released and is now the stable release: it used to be
‘testing’.
Buster, (Debian-10), has changed from ‘stable’ to ‘oldstable’

The last thing you want to do is pin to “stable” because you are now
running oldstable, and don’t have any stable repositories configured.

Did Debian not see this error coming? Yes, they did, and in fact a
change was pushed to “apt” to ignore these changes in the Suite value,
back in April. (Memory could play me false.)
So my guess is that you didn’t update this template before the release
of bullseye - perhaps it was a new 4.0.4 install, or a clean template you’ve
just reinstalled, or you’re not very good at keeping templates updated,
or …

What you can do is run a manual update in that template, when you will
be prompted to acknowledge the change.
Or you can run apt-get update --allow-releaseinfo-change

Once you have the updated version of apt, the problem wont recur.

An updated Qubes template for Bullseye is not yet available for 4.0.

1 Like

Ah, sorry. My answer shared the assumption underlying the question, namely that it was the same problem as the one discussed upthread. Since the Qubes Update tool still uses apt-get under the hood, any apt.conf.d fix that works for apt-get should also work for the Qubes Update tool. But, again, that’s all based on the assumption that it’s the same problem for which the apt.conf.d solution is the correct fix. Since it’s actually a different problem, it’s based on a false assumption, and none of that is applicable.