Debian-10-minimal Configuration

No worries! I couldn’t agree more, some people fail to word the question as complete as possible, then get all bent out of shape when nobody replies, or worse, they are rude when someone tries to help by asking for more info. I guess I should’ve added that most valid point to my little PSA. Thanks for the help!

It’s understandable why people do this when they’ve never learned better. I was probably that way at first too. But it’s also understandable why everyone else would be tired of it, especially after emphasizing how important it is to “help us help you” (along with the rest of the discussion guidelines).

The unjustified rudeness, though, is never excusable — at least not after kindergarten or so. :laughing:

1 Like

I resisted to hijack the topic giving my opinion because I thought hijacking will be over soon, but obviously justified valve is needed for the staff and I absolutely understand that.

I’d like to give my 2 cent.
The first one: whenever I get a chance, I post the link
How To Ask Questions The Smart Way
The second one: I always remember what a friend told me - while traveling a lot all over the world he learned that people’s behavior is more often not wrong then it is, but rather is different (caused by cultural and all other differences).
Interacting with the people from that perspective gives us a better chance to meet somewhere at the middle. (now probably applied for splitting the topic to Forum feedback, hahah)

1 Like

Allow me to go back to Debian Minimal Configuration.

I installed Debian-11-Minimal and the following packages in the template:

printer-driver-hpijs printer-driver-postscript-hp hplip qubes-usb-proxy

I couldn’t get the HP printer to connect to the minimal Qube or to have it recognized. I am able to connect the printer to a Debian-11-based Qube, after installing those same HP printer packages. The Qube recognized it and installed the necessary drivers.

Would anyone know which packages are missing?

1 Like

probably must install cups

Thank you for your reply. I just checked and saw that cups is already installed. It could have installed as dependency or recommended package, when I installed the HP printer driver.

My problem remains.

Thrilled for this, and would also love to give feedback once there’s a draft.

After research on installing a printer to work in Debian 11 minimal, I got it work by installing: system-config-printer - in addition to the printer drivers and qubes-usb-proxy.


Could you please add a few comment lines and the dom0 commands to setup the apt-cacher-ng.

In dom0 (replace $cacher_tempalte with the name of your template:

qvm-run --pass-io -u root $cacher_template "DEBIAN_FRONTEND='noninteractive' apt-get -o Dpkg::Options::='--force-confdef' -o Dpkg::Options::='--force-confold' install --no-install-recommends qubes-core-agent-networking qubes-core-agent-dom0-updates apt-cacher-ng -y"

qvm-run --pass-io -u root $cacher_template "systemctl mask apt-cacher-ng"

qvm-features $cacher_template qubes-firewall 1

Then in the qube that is based on the above template (e.g. sys-firewall):

  1. create /rw/config/qubes-bind-dirs.d/50_user.conf and add
binds+=( '/var/cache/apt-cacher-ng' )
binds+=( '/var/log/apt-cacher-ng' )
binds+=( '/etc/apt-cacher-ng')
  1. add these lines to /rw/config/rc.local
systemctl unmask apt-cacher-ng
systemctl start apt-cacher-ng
iptables -I INPUT -p tcp --dport 8082 -j ACCEPT
  1. restart the qube and then change Port: to 8082 in /etc/apt-cacher-ng/acng.conf

  2. restart again and run sudo systemctl status apt-cacher-ng to see if it’s all setup correctly now.

1 Like

Page not found 404

But for me, creating and cloning template via salt doesn’t work

I’m sorry, only re-reading your post did I realize what it is you are asking for.

qvm-run --pass-io -u root

That’s just what you need to run a command inside a qube and passing the console output to your dom0 terminal. The -u root makes sure the command runs as root, so no sudo needed.

DEBIAN_FRONTEND='noninteractive' apt-get -o Dpkg::Options::='--force-confdef' -o Dpkg::Options::='--force-confold'

When you install the apt-cacher-ng package manually, you will be presented with a screen asking you to choose some options. The above series of parameters makes it so there is no interactive dialog (noninteractive) and the package gets installed with the default options (confdef) and already existing configurations are not overwritten (force-confold).


Just the essentials, not extra packages please.

qubes-core-agent-networking qubes-core-agent-dom0-updates apt-cacher-ng -y"

… the packages and say ‘yes’ to any prompts.

If you are uncomfortable with the above, simply do this:

  1. In dom0: qvm-run my_template xterm … replace my_template with the name of your template. This will give you a terminal window of your template.

  2. Inside the template terminal window sudo apt install --no-install-recommends qubes-core-agent-networking qubes-core-agent-dom0-updates apt-cacher-ng and then answer the prompts.

In any case, before someone else points it out again: if the above is gibberish to you and you feel the need to ask for clarification / unable to clarify the meaning yourself using a search engine of your choice … minimal templates and/or apt-cacher-ng maybe outside your current skill level and might lead to some frustration. Then again, that’s how you grow your skill level… so, you’ve been warned! :wink:

No, your previous reply matched my question :slight_smile:
In your actual reply you mixed up the text format.

Unfortunately, I am busy with other tasks but setup Qubes based on minimal templates is the next chapter in my Qubes learning journey.

I will share my success, questions, summary next week.

Thanks again.

Fixed it. It was a single missing character that did all that. :wink:

Just recently found out about this thread and I think it may just be the right place for a question I posted separately:

Long story short: I customized a debian-11-minimal AppVM which works fairly well with all usb block devices, except with Yubikeys. I’m convinced it must be a missing package because the classic debian-11 template handles it with no issues at all, but I can’t figure out which since I’ve already tried with qubes-u2f , qubes-usb-proxy , qubes-input-proxy-sender , qubes-input-proxy-receiver.
(Mind that all other necessary packages to normally handle a Yubikey have been installed)

I do have a separate sys-usb but I excluded that’s the issue for the reason mentioned above.

I hope this doesn’t constitute thread hijacking!
Thank you all

Well, it is thread hijacking. Please answer this request in it’s dedicated thread and not here. Thank you!

My apologies, I thought it could’ve been a good idea given it’s related to a minimal template.

1 Like

Added your RSS, I am looking forward to your minimizing Qubes, maximizing security guide. :nerd_face:


I think there is 4. option here availble:

  1. Put “User” to “plugdev” group.

then you wont need passwordless sudo package and can still mount external devices.

1 Like