Dead icon/link after fedora upgrades

OK finished upgrading fedora but I have a dead icon. Up in the top left corner the blue “Q”, when I hit it, it drops down there I see all templates appvms… etc.
We’ll I now have this (fedora-30-dvm1-vm) icon and it doesn’t work anymore. So how do I delete or remove it?

I just want to clean things up, if you know what I mean.

Could be a cache somewhere? Same result after booting hardware?

You likely have an entry still under ~/.local/share/applications - check
there and delete it if found.

thanks uman, do I execute that in “dom0”?
or file manager to get to these applications

This might help:

Unfortunately this 2 cmds did not work…I get these errors…
When I use cmd…qvm-appmenus --update --force fedora-30-dvm1-vm…I get this error

Desktop]$ qvm-appmenus --update --force fedora-30-dvm1-vm
Traceback (most recent call last):
File “/usr/bin/qvm-appmenus”, line 9, in
load_entry_point(‘qubesdesktop==4.0.21’, ‘console_scripts’, ‘qvm-appmenus’)()
File “/usr/lib/python3.5/site-packages/qubesappmenus/”, line 637, in main
vm =[vm]
File “/usr/lib/python3.5/site-packages/qubesadmin/”, line 92, in getitem
raise KeyError(item)
KeyError: ‘fedora-30-dmv1-vm’

When I use cmd… rm -i ~/.local/share/applications/fedora-30-dvm1-vm-…I get this error…
rm: cannot remove '/home/user name/.local/share/applications/fedora-30-dvm1-vm-
’: No such file or directory

Can someone please help as it’s a dead app link and I like to keep things nice and clean…
When I let my mouse land on this “app link” fedora-30-dvm1-vm…it states…fedora-30-dvm1-vm: Start qube

those cmds didn’t work for me. So I had to manually delete the file, problem solved!!!