Dark mode in debian minimal

I can’t understand how to enable the theme.
I placed it in the /usr/share/themes, but whenever I use xfconf-query -c xsettings -p /Net/ThemeName -s "My-Theme-Name" it just doesn’t apply.
I searched also for the User Interface Settings or Appearance Settings packages to set it with GUI, but couldn’t find any.
Can someone help please

Qubes themes are decided by dom0. Not the templates (unless you have a GUIVM but I guess it is not the case)

I could change themes of regular templates without issues with the appearance application or with command line, but with the minimal templates, I don’t have that option.
Maybe because I use KDE?

1 Like

Yes. You are right. There are some parts that could be changed from the VM settings. Not just the template as child AppVMs could have their individual appearances. But the overall look and feel (e.g. Panel) is done from the GUIVM. Take the below screenshot as an example.

Setting of the right window only changes the appearance of Applications of personal VM. Only Within the green area. And it could be XFCE based, GNOME based or KDE based. It is regardless of the host desktop environment.

Similarly the setting of the middle window only changes the appearance of what you see within the Blue Window.

The left one is the dom0 setting. It will change the top panel, itself and even the title font of the green and blue windows. But not what is rendered inside them.

p.s.: And do not get confused if the Icon of the personal window is not tinted. I am using something home brew for different icon effects/VM.

Yes, I know all of that.
I don’t know how to deal with the appearance settings in minimal templates.

Do you want it specifically for xterm? Some Apps are not theme aware at all.

Because there’s no such application in minimal templates and I don’t know what package is responsible for this.
Or even better, how to deal with this without any package and with command line.

Is this very stupid question or no one is caring about dark mode?

No, not for specific application, but in general - I want to change a theme. Same as with “Adwaita dark” for example. Global theme

Unfortunately sometimes people get stuck with legacy piece of software which are not theme aware and it is hard-coded. For example the Qubes Systray icon effect which has always white background. This bug has been open since 2017:

If you’re truly working with a minimal template then there isn’t an idea of global theme anymore (to the extent there ever is a global theme concept in desktop Linux). Particular apps you have installed in that minimal template might be able to be themed individually.

1 Like

XFCE uses xsettingsd and GNOME uses gnome-settings-daemon

I installed both of these just now, but none of them provided the appearance application, what am I doing wrong here please?

Does any of the commands work?

xfconf-query -c xsettings -p /Net/ThemeName -s "new-theme"

gsettings set org.gnome.desktop.interface gtk-theme "new-theme"

gsettings set org.gnome.desktop.interface color-scheme 'prefer-dark'

Unfortunately, but no.
xfconf-query says that "/Net/ThemeName" does not exist on channel "xsettings"
The gsettings don’t seem to apply the theme. I tried some of them.
Maybe I should do something else and I’m missing it? Any ideas?

Does anyone actually use dark mode in minimal templates?
Do you use it as global theme, same as with Adwaita dark in regular templates or per application?
Can you please describe your way of doing this, because I’m honestly losing hair here with this issue.

Yes, no problem at all.

Debian 12 Minimal with gnome-settings-daemon installed.

I can change the settings with gsettings.
gsettings set org.gnome.desktop.interface gtk-theme "new-theme"

You might get more useful advice if you write more specifically about what’s lacking in your case. What programs are you installing in your minimal templates that you want to have dark theming?

I use minimal templates for a bunch of qubes. Browser qubes, I set a dark theme within the browser preferences. Other qubes just host xterms and I use an ~/.Xresources file to implement light text on dark background.

1 Like

I don’t get it…
I downloaded debian 12 minimal.
I installed networking package, thunar and gnome-settings-daemon.
I downloaded the theme in other qube, extracted it and moved it to /usr/share/themes in debian 12 minimal.
executed two gsettings commands that you said and nothing, absolutely nothing happened.

Afterwards tried bunch of other things and none of them worked either…

I’m using Debian 12 with GNOME Terminal and Nautilus, which might be why gsettings is working for me.

The Arch wiki lists the different options depending on if you are using XFCE, GNOME, KDE, etc.