Ctrl+Shift+v stopped working

Hi all,

Somehow Ctrl+Shift+v stopped working for me! Ctrl+Shift+c works and see the popup on the top right reporting the correct number of bytes copied, but I can’t paste it in any VM. I have tried pasting within Debian 10 / Fedora 33,34 VMs, but no luck so far.

The /etc/qubes-rpc/policy/qubes.ClipboardPaste file is untouched, and the only change I made recently was update the qubes-gui-daemon and qubes-audio-daemon in dom0 from current-testing.

Any idea what could be going on? What log files could I look at to find out more about the issue?

Thanks

You could check Qubes Global Settings to make sure the combination is set to Ctrl+Shift+V instead of something else?

Thanks, I have checked both the “Qubes Global Settings” and /etc/qubes/guid.conf in dom0 and none of them override the default Ctrl+Shift+v

the only change I made recently was update the qubes-gui-daemon and qubes-audio-daemon in dom0 from current-testing

Turns out this ^ was the problem: I cherry picked 2 packages from current-testing (because I just wanted the fix for #6518). After trying many different tweaks, I decided to do a full dom0 upgrade to current-testing:

qubes-dom0-update --enablerepo=qubes-dom0-current-testing

and that fixed the issue after a restart.

1 Like

Cherry picking updated packages is never a good idea - although the
dependencies should be set to pull in associated packages, it’s not
guaranteed to work.
It’s always better to run a full update, as you have found.