Cryptostorm does not work on Qubes 4.1?

Is there anyone with a working VPN who can see if any of Cryptostorm’s configs work? I used to use these on 4.0 and pfSense, but I’ve been struggling off an on since then to get connected. I’ve tried with Qubes-vpn-support, qubes-tunnel, Fedora templates, Debian templates, minimal templates, going through sys-firewall, sys-whonix, but openvpn blames network connectivity or fails negotiating the TLS connection. Even using the network manager in sys-net doesn’t work.

Free configs are here: cryptostorm_client_configuration_files/cryptofree at master · cryptostorm/cryptostorm_client_configuration_files · GitHub


This is what happens when I try to connect with Fedora 36 sys-net. does not respond to ping so I disabled it, but it doesn’t change this.


The VPN troubleshooting section says to check this. Ok… so what? What am I looking for? Is this correct? If not, why?

You should create a new AppVM to install your VPN. sys-net should not be touched unless you have to tweak something wifi/ethernet related. Once you’ve done that, try again and see what it says.

I’ve tried that already in many different configurations. It doesn’t make a difference.

Can you try the same installation on debian? Fedora changed a lot of policy regarding cryptography lately. If this still doesn’t work, then it could be your router blocking the request or it’s a problem from the VPN provider.

No, Debian 11 doesn’t work either. Even when trying to connect over Tor using the TCP configuration to rule out the router and firewall. I guess something could be wrong with Cryptostorm, but that’s why I’m asking someone to try it. I don’t have anything else to test with right now.

I tried it and I have the same TLS error issue. It’s coming from the VPN provider for sure.

1 Like