Cryptographic hash verification issues

I’m in the process of upgrading from 4.1 to 4.2 using the clean install method. During the verification process, when I try to check the digests I have ran into trouble.
Entering md5sum -c Qubes-R4.2.0-x86_64.iso.DIGESTS returns md5sum: Qubes-R4.2.0-x86_64.iso.DIGESTS: No such file or directory

The file does exist and is located in /home/user/Downloads where the iso, signing-key.asc, and iso.asc files are also located.

I don’t remember how I did this with 4.1 or running into this. I’ve looked at the documentation and searched the forum, but have yet to find what I’m doing wrong here.

Are you running this command from /home/user/Downloads directory?

cd /home/user/Downloads
md5sum -c Qubes-R4.2.0-x86_64.iso.DIGESTS

Are you sure you are in the same directory when you run this command?

It works with md5sum for me. You should probably use sha256sum or sha512sum instead since md5 is not recommended.

1 Like

The error is unrelated to the fact that the OP is using md5sum. Once the MD5 hashes verified, they’ll be able to verify the other ones, but this advice is premature until they can run the command they’re trying to run successfully.

1 Like

I know. This is an addition to my first sentence in the same post, which is simply an advice for the future.

I believe I am in the same directory. I’m using the terminal to that vm, and it’s worked for checking the other files prior to checking hash.
I intend to check using all 4 sum commands, but stopped after the first one returned no file or directory.

Can you run pwd in that terminal and check that you are in the same directory as your ISO and digest file?


Yes, /home/user This is where all of the 4.2 files I downloaded are.

In your main post you stated that your files are located in /home/user/Downloads. You need to move to the Downloads directory for your command to work.

1 Like

Is the terminal not capable of accessing Downloads from here? It worked for checking the signatures and fingerprints also in the Downloads folder. I’m not sure I know how to move to the Downloads directory.

The command you used looks for the file in the directory you’re currently in, which doesn’t contain any of your files. You must be in the same directory so the command can find them.
Use cd Downloads

1 Like

That worked and all sum commands check out ok.

I’m curious why I was able to verify the iso.asc and iso files prior to switching directories. All 4 of the 4.2 files I downloaded are in the same Downloads folder, and I could access them for verification from /home/user

Thank you for helping me with this.

1 Like

I marked your answer as solution, but you’ll have to wait for heart’s. I used my allowance on the meme thread today. :wink:


Hi, sorry for not responding to your reply. I did not even see it at the time. The information you gave is pretty much the same as what I followed to fix my issue. Thank you for taking the time to reply to my post, and offering assistance with the issue.

1 Like